Marriage Match II HDU - 3081 (二分答案+最大流+并查集)

本文探讨了一个有趣的问题:如何计算在特定条件下孩子们能进行多少轮稳定婚姻匹配游戏。通过使用二分查找结合最大流算法,并利用并查集处理人际关系,文章提供了一种有效的解决方案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Presumably, you all have known the question of stable marriage match. A girl will choose a boy; it is similar as the game of playing house we used to play when we are kids. What a happy time as so many friends playing together. And it is normal that a fight or a quarrel breaks out, but we will still play together after that, because we are kids.
Now, there are 2n kids, n boys numbered from 1 to n, and n girls numbered from 1 to n. you know, ladies first. So, every girl can choose a boy first, with whom she has not quarreled, to make up a family. Besides, the girl X can also choose boy Z to be her boyfriend when her friend, girl Y has not quarreled with him. Furthermore, the friendship is mutual, which means a and c are friends provided that a and b are friends and b and c are friend.
Once every girl finds their boyfriends they will start a new round of this game—marriage match. At the end of each round, every girl will start to find a new boyfriend, who she has not chosen before. So the game goes on and on.
Now, here is the question for you, how many rounds can these 2n kids totally play this game?
Input
There are several test cases. First is a integer T, means the number of test cases.
Each test case starts with three integer n, m and f in a line (3<=n<=100,0<m<nn,0<=f<n) . n means there are 2*n children, n girls(number from 1 to n) and n boys(number from 1 to n).
Then m lines follow. Each line contains two numbers a and b, means girl a and boy b had never quarreled with each other.
Then f lines follow. Each line contains two numbers c and d, means girl c and girl d are good friends.
Output
For each case, output a number in one line. The maximal number of Marriage Match the children can play.
Sample Input
1
4 5 2
1 1
2 3
3 2
4 2
4 4
1 4
2 3
Sample Output
2

模板大法好
因为 答案小于人数,才100,二分一下,嵌套一个最大流,人和人的关系就并查集了

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=205;
const int maxx=20405;
int edge;
int to[maxx],flow[maxx],nex[maxx];
int head[maxn];

void addEdge(int v,int u,int cap)
{
    to[edge]=u,flow[edge]=cap,nex[edge]=head[v],head[v]=edge++;
    to[edge]=v,flow[edge]=0,nex[edge]=head[u],head[u]=edge++;
}
int vis[maxn];
int pre[maxn];
bool bfs(int s,int e)
{
    queue<int> que;
    pre[s]=-1;
    memset(vis,-1,sizeof(vis));
    que.push(s);
    vis[s]=0;
    while(!que.empty())
    {
        int u=que.front();
        que.pop();
        for(int i=head[u];~i;i=nex[i])
        {
            int v=to[i];
            if(vis[v]==-1&&flow[i])
            {
                vis[v]=vis[u]+1;
                if(v==e)
                    return true;
                que.push(v);
            }

        }
    }
    return false;
}
int dfs(int s,int t,int f)
{
    if(s==t||!f)
        return f;
    int r=0;
    for(int i=head[s];~i;i=nex[i])
    {
        int v=to[i];
        if(vis[v]==vis[s]+1&&flow[i])
        {
            int d=dfs(v,t,min(f,flow[i]));
            if(d>0)
            {
                flow[i]-=d;
                flow[i^1]+=d;
                r+=d;
                f-=d;
                if(!f)
                    break;
            }
        }
    }
    if(!r)
        vis[s]=INF;
    return r;
}
int maxFlow(int s ,int e)//然后直接调用这个即可
{
    int ans=0;
    while(bfs(s,e))
        ans+=dfs(s,e,INF);
    return ans;
}
int fa[105];
int findd(int x)
{
    return fa[x]==x?x:fa[x]=findd(fa[x]);
}
bool dist[maxn][maxn];
void init()//记得每次使用前初始化
{
    memset(head,-1,sizeof(head));
    edge=0;
}
bool check(int n,int limit)
{
    init();
    for(int i=1;i<=n;i++)
        for(int j=n+1;j<=n*2;j++)
            if(dist[i][j])
                addEdge(i,j,1);
    for(int i=1;i<=n;i++)
        addEdge(0,i,limit);
    for(int i=1;i<=n;i++)
        addEdge(i+n,n+n+1,limit);
    return maxFlow(0,n+n+1)==n*limit;
}
int main()
{
    int t;
    int n,m,f;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&f);
        for(int i=1;i<=n;i++)
            fa[i]=i;
        memset(dist,false,sizeof(dist));
        while(m--)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            dist[u][v+n]=true;
        }
        while(f--)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            int uu=findd(u);
            int vv=findd(v);
            if(uu!=vv)
                fa[uu]=vv;
        }
        for(int i=1;i<=n;i++)
            for(int j=i+1;j<=n;j++)
                if(findd(i)==findd(j))
                    for(int k=n+1;k<=n*2;k++)
                        dist[i][k]=dist[j][k]=(dist[i][k]||dist[j][k]);
        int l=0,r=100;
        while(l<=r)
        {
            int mid=(l+r)>>1;
            if(check(n,mid))
                l=mid+1;
            else
                r=mid-1;
        }
        printf("%d\n",r);
    }
}
关于“Marriage Matching 3190”,经过网络搜索发现这可能是一个特定编号的问题或者算法题目,通常出现在编程竞赛、学术研究或计算机科学领域中的匹配问题讨论中。以下是对此主题的详细解答: --- ### 方法一:理解婚姻匹配的基本概念 婚姻匹配问题是图论和组合优化领域的经典问题之一,主要涉及如何在一组男性和女性之间找到稳定的配对关系。稳定婚配问题(Stable Marriage Problem, SMP)由Gale和Shapley于1962年提出,其核心目标是在给定偏好列表的情况下避免不稳定配对。 对于编号为3190的具体问题,可能是某个平台上的变种版本,例如增加约束条件或调整输入输出形式。 --- ### 方法二:实现 Gale-Shapley 算法解决基本问题 经典的解决方案是使用 Gale-Shapley 算法来求解稳定婚配问题。该算法的核心思想如下: 1. 每位单身男子向他尚未求婚过的最喜欢女子求婚。 2. 女子从当前收到的所有求婚者中选择她最喜欢的未婚男子,并暂时接受他的求婚。 3. 如果某女子已经订婚但收到了更优的选择,则解除现有订婚并将原伴侣重新归入单身状态。 4. 重复以上过程直到所有人都成功配对为止。 下面是 Gale-Shapley 算法的一个简单 Python 实现: ```python def gale_shapley(men_prefs, women_prefs): n = len(men_prefs) free_men = list(range(n)) engaged = [-1] * n proposals = [0] * n while free_men: man = free_men.pop(0) woman = men_prefs[man][proposals[man]] proposals[man] += 1 if engaged[woman] == -1: engaged[woman] = man else: current_man = engaged[woman] if women_prefs[woman].index(man) < women_prefs[woman].index(current_man): free_men.append(current_man) engaged[woman] = man else: free_men.append(man) return {w: m for w, m in enumerate(engaged)} # 示例数据 men_prefs = [[0, 1, 2], [1, 2, 0], [2, 0, 1]] women_prefs = [[1, 2, 0], [0, 1, 2], [2, 1, 0]] result = gale_shapley(men_prefs, women_prefs) print(result) ``` --- ### 方法三:针对特殊编号问题的扩展思考 如果“3190”代表某种特殊的限制条件或复杂场景,可以考虑以下方向进行改进: - **加权匹配**:引入权重表示每对之间的亲密度或其他指标,寻找总权重最大的匹配方案。 - **多对多匹配**:允许一个人同时与多人建立联系,适用于社交网络分析等实际应用。 - **动态更新机制**:当参与者的偏好随时间变化时,设计实时调整策略以保持稳定性。 具体实现需要结合问题描述进一步明确规则及边界情况。 --- ### 方法四:查找在线资源获取完整信息 由于“Marriage Matching 3190”可能来源于某些特定网站或书籍章节,建议访问以下渠道了解详情: - 编程竞赛平台(如LeetCode、Codeforces、AtCoder),搜索关键词“marriage matching”查看是否有对应编号的任务; - 学术论文数据库(Google Scholar、ResearchGate),查阅有关SMP及其衍生模型的研究成果; - 开源社区论坛(Stack Overflow、GitHub Issues),与其他开发者交流经验心得。 ---
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值