poj 2488 A Knight's Journey

题意:给你一个n*m的矩阵,看能从(1,1)点开始按照字典序开始遍历,能否遍历n*m内的所有的点

盗张图~~ 没找到,但我见到过,、等找到再发吧~~

按照字典序遍历,其实就是规定遍历的优先方向,也就是下面这个

int Dir[][2] = {{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <set>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#define LL long long
#define INF 0x3f3f3f3f
#define RR freopen("in.txt","r",stdin)
//#pragma comment(linker,"/SATACK,;1024000,1024000")
#define MAX 1100
using namespace std;
int Dir[][2] = {{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};
bool vis[MAX][MAX];
struct node
{
    int row;
    char cal;
} way[MAX];
int p,q;
bool flag;
int Max_step;

void DFS(int x,int y,int step)
{
    if(step == Max_step)
    {
        for(int i=1; i<=Max_step; i++)
        {
            printf("%c%d",way[i].cal,way[i].row);
        }
        printf("\n");
        flag = true;
        return ;
    }

    for(int i=0; i<8 && !flag ; i++)
    {
        int xx = x + Dir[i][0];
        int yy = y + Dir[i][1];
        if(!vis[xx][yy] && xx > 0 && yy > 0 && xx <= q && yy <= p)
        {
            way[step+1].cal = 'A' + xx - 1;
            way[step+1].row = yy;
            vis[xx][yy] = true;
            DFS(xx,yy,step+1);
            vis[xx][yy] = false;
        }
    }



}
int main()
{
    // RR;
    int n;
    int t = 0;
    cin>>n;
    while(n--)
    {
        cin>>p>>q;
        printf("Scenario #%d:\n",++t);
        Max_step = p * q;
        memset(vis,false,sizeof(vis));
        flag = false;
        way[1].cal = 'A';
        way[1].row = 1;
        vis[1][1] = true;
        DFS(1,1,1);
        if(!flag)
            printf("impossible\n");
        printf("\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值