Max Sum Plus Plus
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37350 Accepted Submission(s): 13331
Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.
Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).
Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).
But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8
题意:将含有n个元素的数列从中选取M段,输出M段的最大和。
思路讲解:https://blog.youkuaiyun.com/ray_seu/article/details/8547205,初始化什么的,不怎么好理解,还有一篇没有最优化,好理解点:https://blog.youkuaiyun.com/qiqi_skystar/article/details/50599816
312MS , 6724K
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1000000
int dp[N+10];
int mat[N+10];
int w[2][N+10];
int sum[N+10];
int main()
{
int n,m;
while(~scanf("%d%d",&m,&n)) {
sum[0]=0;
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++) {
scanf("%d",&mat[i]);
sum[i]=sum[i-1]+mat[i];
w[0][i]=0;
}
int t=1;
for(int i=1;i<=m;i++) {
w[t][i]=dp[i]=sum[i];
for(int j=i+1;j<=n-m+i;j++) {
dp[j]=max(dp[j-1],w[1-t][j-1])+mat[j];
w[t][j]=max(dp[j],w[t][j-1]);
}
t=1-t;
}
printf("%d\n",w[m%2][n]);
}
return 0;
}
452MS, 9592K
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define N 1000000
#define INF 0x7fffffff
int a[N+10];
int dp[N+10],Max[N+10];//max( dp[i-1][k] ) 就是上一组 0....j-1 的最大值。
int main()
{
int n,m,mmax;
while (~scanf("%d%d",&m,&n))
{
for (int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
memset(dp,0,sizeof(dp));
memset(Max,0,sizeof(Max));
for (int i=1;i<=m;i++)//分成几组
{
mmax=-INF;
for (int j=i;j<=n;j++)//j个数分成i组,至少要有i个数
{
dp[j]=max(dp[j-1]+a[j],Max[j-1]+a[j]);
Max[j-1]=mmax;
mmax=max(mmax,dp[j]);
}
}
printf ("%d\n",mmax);
}
return 0;
}