Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2 3 4
Sample Output
7 6HintIn the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
#include <stdio.h>
int ans[10][4];
int main(){
int T,n,i,j;
ans[0][0] = ans[0][1] = ans[0][2] = ans[0][3]=0;
ans[1][0] = ans[1][1] = ans[1][2] = ans[1][3]=1;
ans[2][0]=6;ans[2][1]=2;ans[2][2]=4;ans[2][3]=8;
ans[3][0]=1;ans[3][1]=3;ans[3][2]=9;ans[3][3]=7;
ans[4][0]=6;ans[4][1]=4;ans[4][2]=6;ans[4][3]=4;
ans[5][0] = ans[5][1] = ans[5][2] = ans[5][3]=5;
ans[6][0] = ans[6][1] = ans[6][2] = ans[6][3]=6;
ans[7][0]=1;ans[7][1]=7;ans[7][2]=9;ans[7][3]=3;
ans[8][0]=6;ans[8][1]=8;ans[8][2]=4;ans[8][3]=2;
ans[9][0]=1;ans[9][1]=9;ans[9][2]=1;ans[9][3]=9;
scanf("%d",&T);
while(T--){
scanf("%d",&n);
i=n%10;
j=n%4;
printf("%d\n",ans[i][j]);
}
return 0;
}