HDU:5748 Bellovin(LIS+打表)

Bellovin

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1103    Accepted Submission(s): 498


Problem Description
Peter has a sequence   a1,a2,...,an  and he define a function on the sequence --   F(a1,a2,...,an)=(f1,f2,...,fn) , where   fi  is the length of the longest increasing subsequence ending with   ai .

Peter would like to find another sequence   b1,b2,...,bn  in such a manner that   F(a1,a2,...,an)  equals to   F(b1,b2,...,bn) . Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence   a1,a2,...,an  is lexicographically smaller than sequence   b1,b2,...,bn , if there is such number   i  from   1  to   n , that   ak=bk  for   1k<i  and   ai<bi .
 

Input
There are multiple test cases. The first line of input contains an integer   T , indicating the number of test cases. For each test case:

The first contains an integer   n   (1n100000)  -- the length of the sequence. The second line contains   n  integers   a1,a2,...,an   (1ai109) .
 

Output
For each test case, output   n  integers   b1,b2,...,bn   (1bi109)  denoting the lexicographically smallest sequence.
 

Sample Input
  
  
3 1 10 5 5 4 3 2 1 3 1 3 5
 

Sample Output
  
  
1 1 1 1 1 1 1 2 3
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5831  5830  5829  5828  5827 
 
题目大意:给你一个数字序列,让你求出以每个a[i]结尾的最长递增子序列长度,并且输出。
解题思路:新开一个dp数组记录以每个a[i]结尾的最长递增子序列长度,其余的都是裸LIS。
代码如下:
#include <cstdio>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int dp[100010];//记录以第i个数字为尾的最长子序列长度 
int d[100010];//辅助数组 
int a[100010];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			d[i]=INF;//初始化辅助数组 
			dp[i]=0;//初始化dp 
		}
		for(int i=1;i<=n;i++)
		{
			int pos=lower_bound(d+1,d+n+1,a[i])-d;//找到当前a[i]能插的点 
			dp[i]=max(dp[i],pos);//更新下dp 
			d[pos]=min(d[pos],a[i]);//将a[i]插入辅助数组 
		}
		for(int i=1;i<n;i++)
		{
			printf("%d ",dp[i]);
		}
		printf("%d\n",dp[n]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值