Bellovin
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 1103 Accepted Submission(s): 498
Problem Description
Peter has a sequence
a1,a2,...,an
and he define a function on the sequence --
F(a1,a2,...,an)=(f1,f2,...,fn)
, where
fi
is the length of the longest increasing subsequence ending with
ai
.
Peter would like to find another sequence b1,b2,...,bn in such a manner that F(a1,a2,...,an) equals to F(b1,b2,...,bn) . Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.
The sequence a1,a2,...,an is lexicographically smaller than sequence b1,b2,...,bn , if there is such number i from 1 to n , that ak=bk for 1≤k<i and ai<bi .
Peter would like to find another sequence b1,b2,...,bn in such a manner that F(a1,a2,...,an) equals to F(b1,b2,...,bn) . Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.
The sequence a1,a2,...,an is lexicographically smaller than sequence b1,b2,...,bn , if there is such number i from 1 to n , that ak=bk for 1≤k<i and ai<bi .
Input
There are multiple test cases. The first line of input contains an integer
T
, indicating the number of test cases. For each test case:
The first contains an integer n (1≤n≤100000) -- the length of the sequence. The second line contains n integers a1,a2,...,an (1≤ai≤109) .
The first contains an integer n (1≤n≤100000) -- the length of the sequence. The second line contains n integers a1,a2,...,an (1≤ai≤109) .
Output
For each test case, output
n
integers
b1,b2,...,bn
(1≤bi≤109)
denoting the lexicographically smallest sequence.
Sample Input
3 1 10 5 5 4 3 2 1 3 1 3 5
Sample Output
1 1 1 1 1 1 1 2 3
Source
Recommend
题目大意:给你一个数字序列,让你求出以每个a[i]结尾的最长递增子序列长度,并且输出。
解题思路:新开一个dp数组记录以每个a[i]结尾的最长递增子序列长度,其余的都是裸LIS。
代码如下:
#include <cstdio>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int dp[100010];//记录以第i个数字为尾的最长子序列长度
int d[100010];//辅助数组
int a[100010];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
d[i]=INF;//初始化辅助数组
dp[i]=0;//初始化dp
}
for(int i=1;i<=n;i++)
{
int pos=lower_bound(d+1,d+n+1,a[i])-d;//找到当前a[i]能插的点
dp[i]=max(dp[i],pos);//更新下dp
d[pos]=min(d[pos],a[i]);//将a[i]插入辅助数组
}
for(int i=1;i<n;i++)
{
printf("%d ",dp[i]);
}
printf("%d\n",dp[n]);
}
return 0;
}