1015. Reversible Primes (20)

本文介绍了一种算法,用于判断一个数是否为特定进制下的可逆素数。可逆素数指在一个进制中,该数及其反转形式均为素数的情况。文章详细解释了素数判断及进制转换的方法,并提供了完整的C++代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

题意

Reversible Primes 是指在某个进制下,一个数本身和它翻转过来形成的新数都是素数。 题中给出多组数据,以负数结尾程序。每组数据包含一个数以及一个进制数。判定该数是否是 Reversible Primes.

分析

两个功能点实现:判定素数和特定进制下的数据倒转。

#include <iostream>
#include <math.h>

int convert(int N,int D){
   int num=0;
   while(N!=0){
   num=num*D+N%D;
   N=N/D;
  }
   return num;
}

bool IsPrime(int n){
	if(n==0||n==1)
		return false;
	else
		 for(int i = 2; i <= sqrt((double)n); ++i){
			if(n%i==0)
				return false;
		}
		return true;
}

int main(){
	int N,D;
	while (scanf("%d",&N)!=EOF&&N>=0){
		scanf("%d",&D);
		if(IsPrime(N)&&IsPrime(convert(N,D)))
			printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值