A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.
Sample Input:73 10 23 2 23 10 -2Sample Output:
Yes Yes No
题意
Reversible Primes 是指在某个进制下,一个数本身和它翻转过来形成的新数都是素数。 题中给出多组数据,以负数结尾程序。每组数据包含一个数以及一个进制数。判定该数是否是 Reversible Primes.
分析
两个功能点实现:判定素数和特定进制下的数据倒转。
#include <iostream>
#include <math.h>
int convert(int N,int D){
int num=0;
while(N!=0){
num=num*D+N%D;
N=N/D;
}
return num;
}
bool IsPrime(int n){
if(n==0||n==1)
return false;
else
for(int i = 2; i <= sqrt((double)n); ++i){
if(n%i==0)
return false;
}
return true;
}
int main(){
int N,D;
while (scanf("%d",&N)!=EOF&&N>=0){
scanf("%d",&D);
if(IsPrime(N)&&IsPrime(convert(N,D)))
printf("Yes\n");
else printf("No\n");
}
return 0;
}