hdu 4791 Alice's Print Service 二分

Problem Description
Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , ..., s n, p n (0=s 1 < s 2 < ... < s n≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ ... ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 .. q m (0 ≤ q i ≤ 10 9 ) are the queries.
 

Output
For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.
 

Sample Input
  
  
1 2 3 0 20 100 10 0 99 100
 

Sample Output
  
  
0 1000 1000
 


题意:

当打印达到一定的数量就会相应的便宜,现在给出打印的张数和对应的价格,求打印的最少花费。


思路:

求出所有节点的花费,并统计大于x张时的最低价。二分查找大于询问张数的节点。


#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define ll long long 
using namespace std;
const int N=110000;
ll a[N],b[N],c[N],d[N];


int bSearch(int _begin, int _end, ll e)
{
	int mid, left = _begin, right = _end;
	while(left <= right)
	{
		mid = (left + right) >> 1;
		if(a[mid] >= e) right = mid - 1;
		else left = mid + 1;
	}
	return left;
}

int main(int argc, const char * argv[]) {
    int T,n,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%lld%lld",&a[i],&b[i]);
            c[i]=a[i]*b[i];
        }
        d[n-1]=c[n-1];
        for(int i=n-2;i>=0;i--)
            d[i]=min(d[i+1],c[i]);
        for(int i=0;i<m;i++)
        {
            ll t;
            scanf("%lld",&t);
            if(n==1)    {printf("%lld\n",t*b[0]);continue;}
            if(t>=a[n-1])   {printf("%lld\n",t*b[n-1]);continue;}
            int p=bSearch(0, n-1, t);
            ll ans;
            if(a[p]==t) ans=d[p];
            else    ans=min(d[p],b[p-1]*t);
            if(t==0)    ans=0;
            printf("%lld\n",ans);
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值