The sum problem
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 19582 Accepted Submission(s): 5772
Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
Sample Input
20 10 50 30 0 0
Sample Output
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
Author
8600
Source
Recommend
我想 这就叫算法吧,利用高斯求和,进行反解,由于解出a1比较难,就解出了n:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;//2*s=(2*a1+n-1)*n;
long i,j,k,l,m,n;
double help;
int main()
{
while(scanf("%ld%ld",&m,&n),m+n)
{
help=sqrt(2*n+1);
if(m<help)
help=m;
for(i=help+1;i>=1;i--)
{
l=(n*2+i-i*i)/2/i;
if(i*i-i+2*l*i==2*n&&l>0&&(i%2==0||(2*l+i-1)%2==0))
printf("[%ld,%ld]\n",l,i+l-1);
}
printf("\n");
}
}