杭电2058 The sum problem

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19582    Accepted Submission(s): 5772


Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 

Sample Input
  
  
20 10 50 30 0 0
 

Sample Output
  
  
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
 

Author
8600
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   2059  2056  2062  2065  2063 
我想 这就叫算法吧,利用高斯求和,进行反解,由于解出a1比较难,就解出了n:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;//2*s=(2*a1+n-1)*n;
long i,j,k,l,m,n;
double help;
int main()
{
	while(scanf("%ld%ld",&m,&n),m+n)
	{
		help=sqrt(2*n+1);
		if(m<help)
		help=m;
		for(i=help+1;i>=1;i--)
		{
			l=(n*2+i-i*i)/2/i;
			if(i*i-i+2*l*i==2*n&&l>0&&(i%2==0||(2*l+i-1)%2==0))
			printf("[%ld,%ld]\n",l,i+l-1);
		}
		printf("\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值