C语言实验——排列
Time Limit: 1000 ms
Memory Limit: 65536 KiB
Problem Description
有4个互不相同的数字,请按序输出由其中三个不重复数字组成的排列。
Input
4个整数。
Output
所有排列,输出顺序见样例。
Sample Input
1 2 3 4
Sample Output
1 2 3 1 3 2 2 1 3 2 3 1 3 1 2 3 2 1 1 2 4 1 4 2 2 1 4 2 4 1 4 1 2 4 2 1 1 3 4 1 4 3 3 1 4 3 4 1 4 1 3 4 3 1 2 3 4 2 4 3 3 2 4 3 4 2 4 2 3 4 3 2
Hint
Source
ZJGSU
//package leslie1;
//import java.io.*;
//import java.math.*;
//import java.text.*;
//import java.math.BigInteger;
import java.util.*;
public class Main {
static int a[] = new int[4];
static int b[] = new int[4];
static int c[] = new int[4];
static int v[] = new int[10086];
public static void DFS(int x) {
for (int i = 0; i < 3; i++) {
if (v[b[i]] == 0) {
v[b[i]] = 1;
c[x] = b[i];
if (x == 3)
for (int j = 1; j <= 3; j++)
System.out.printf("%d%c", c[j], j == 3 ? '\n' : ' ');
else
DFS(x + 1);
v[b[i]] = 0;
}
}
}
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
for (int i = 0; i < 4; i++)
a[i] = cin.nextInt();
Arrays.sort(a);
b[0] = a[0];
b[1] = a[1];
b[2] = a[2];
DFS(1);
Arrays.fill(v, 0);
b[0] = a[0];
b[1] = a[1];
b[2] = a[3];
DFS(1);
Arrays.fill(v, 0);
b[0] = a[0];
b[1] = a[2];
b[2] = a[3];
DFS(1);
Arrays.fill(v, 0);
b[0] = a[1];
b[1] = a[2];
b[2] = a[3];
DFS(1);
cin.close();
}
}