uva1584 Circular Sequence

Circular Sequence

Description

 

Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence ``CGAGTCAGCT", that is, the last symbol ``T" in ``CGAGTCAGCT" is connected to the first symbol ``C". We always read a circular sequence in the clockwise direction.

 

Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence.

Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is ``AGCTCGAGTC". If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).

Input 

The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, A, C, G and T, are allowed. Each sequence has length at least 2 and at most 100.

Output 

Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.

The following shows sample input and output for two test cases.

Sample Input 

2                                    

CGAGTCAGCT                           

CTCC

Sample Output 

AGCTCGAGTC

CCCT

题意:

有一个环状的字符串序列,仅包含四种字符----‘A’、‘T’、‘G’、‘C’。顺时针读取整个序列,需要你在这个环状序列中找到一个起点字符,从这个字符开始顺时针依次读取完整个字符串,使得得到的字符串的字典序最小。

 

输入:

       情况数T,之后T行每行一个字符串表示任意起点字符开始顺时针读取的环形字符串,长度不小于2不大于100。

输出:

       每种情况输出符合字典序最小的字符串解。

 

 

#include<stdio.h>
#include<string.h>
#define maxn 100
char s[maxn],ans[maxn];
int main()
{
	int n;
	char c;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%s",s);
		strcpy(ans,s);
		int i,j,t,len=strlen(s);
		for(i=0;i<len;i++)
		{
			c=s[len-1];
			for(j=len-1;j>=0;j--)
			    s[j]=s[j-1];
			s[0]=c;
			if(strcmp(s,ans)<0)
			    strcpy(ans,s);
		}
		printf("%s\n",ans);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值