PAT 1102 Invert a Binary Tree

本文介绍了一个编程问题,要求在给定的二叉树中实现倒置操作,包括先序遍历(level-ordertraversal)和后序遍历(in-ordertraversal)。作者提供了C++代码示例来解决这个问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

Code:

#include<bits/stdc++.h>

using namespace std;
const int N = 1e5 + 10;
int l[N], r[N], q[N];
bool has_father[N];
int n;

void reverse_dfs(int u) {
    if (u == -1)
        return;
    reverse_dfs(l[u]);
    reverse_dfs(r[u]);
    swap(l[u], r[u]);
}

void bfs(int u) {
    int hh = 0, tt = -1;
    q[++tt] = u;
    while (hh <= tt) {
        int t = q[hh++];
        if (l[t] != -1)
            q[++tt] = l[t];
        if (r[t] != -1)
            q[++tt] = r[t];
    }
    cout << q[0];
    for (int i = 1; i <= tt; i++) {
        cout << " " << q[i];
    }
    cout << endl;
}
void dfs(int u,int &k){
    if(u==-1)
        return;
    dfs(l[u],k);
    cout<<u;
    if(++k!=n)
        cout<<' ';
    dfs(r[u],k);
}
int main() {
    cin >> n;
    memset(l, -1, sizeof l);
    memset(r, -1, sizeof r);
    for (int i = 0; i < n; i++) {
        char lc, rc;
        cin >> lc >> rc;
        if (lc != '-')l[i] = lc - '0', has_father[l[i]] = true;
        if (rc != '-')r[i] = rc - '0', has_father[r[i]] = true;

    }
    int root = 0, k=0;
    while (has_father[root])
        root++;
    reverse_dfs(root);
    bfs(root);
    dfs(root,k);
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值