The following is from Max Howell @twitter:
Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.
Now it's your turn to prove that YOU CAN invert a binary tree!
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a -
will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
Code:
#include<bits/stdc++.h>
using namespace std;
const int N = 1e5 + 10;
int l[N], r[N], q[N];
bool has_father[N];
int n;
void reverse_dfs(int u) {
if (u == -1)
return;
reverse_dfs(l[u]);
reverse_dfs(r[u]);
swap(l[u], r[u]);
}
void bfs(int u) {
int hh = 0, tt = -1;
q[++tt] = u;
while (hh <= tt) {
int t = q[hh++];
if (l[t] != -1)
q[++tt] = l[t];
if (r[t] != -1)
q[++tt] = r[t];
}
cout << q[0];
for (int i = 1; i <= tt; i++) {
cout << " " << q[i];
}
cout << endl;
}
void dfs(int u,int &k){
if(u==-1)
return;
dfs(l[u],k);
cout<<u;
if(++k!=n)
cout<<' ';
dfs(r[u],k);
}
int main() {
cin >> n;
memset(l, -1, sizeof l);
memset(r, -1, sizeof r);
for (int i = 0; i < n; i++) {
char lc, rc;
cin >> lc >> rc;
if (lc != '-')l[i] = lc - '0', has_father[l[i]] = true;
if (rc != '-')r[i] = rc - '0', has_father[r[i]] = true;
}
int root = 0, k=0;
while (has_father[root])
root++;
reverse_dfs(root);
bfs(root);
dfs(root,k);
}