选做题 - 1
We give the following inductive definition of a “regular brackets” sequence:
the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]
while the following character sequences are not:
(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.
Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].
Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive.
The end-of-file is marked by a line containing the word “end” and should not be processed.
Output
For each input case, the program should print the length of the
longest possible regular brackets subsequence on a single line.
Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6
问题分析
令dp[ i ][ j ]表示i到j中匹配的最大子列的长度
初始化 dp[ i ][ i ] = 0
那么
1.如果第j个括号是左括号,则不可能与之前的括号匹配,所以最大匹配子列长度不变。dp[ i ][ j ] = dp[ i ][ j-1 ],
2.如果是右括号:
1.第j个括号不匹配
2.第j个括号与第i~j-1个括号中的一个相匹配
如果第j个括号不匹配,实际上与情况1一致,则dp[ i ][ j ] =dp[ i ][ j-1 ]
如果第j个括号匹配i~j-1中的某个编号为k的括号,那么dp[i][j]表示第i到第j匹配的最大子列长度就表示为第i到第k-1位匹配的最大子列长度+第k+1到j-1位匹配的最大子列长度+2(匹配的第j和第k位括号贡献的长度),则dp[ i ][ j ] = max( dp[ i ][ k -1 ] + dp[ k+1 ][ j -1 ] +2)。要找到能使dp[i][j]最大的那个k
代码实现
#include <iostream>
#include <cstring>
#include <algorithm>
#include <string>
#define maxn 105
using namespace std;
int dp[maxn][maxn];
int main()
{
string s;
while(cin>>s)
{
if(s=="end")
break;
memset(dp,0,sizeof(dp));
for(int j = 0; j < s.size(); ++j)
{
for(int i = j - 1; i >= 0; --i)
{
dp[i][j] = dp[i + 1][j];
for(int k = i + 1; k <= j; ++k)
{
if(s[i] == '(' && s[k] == ')' || s[i] == '[' && s[k] == ']')
dp[i][j] = max(dp[i + 1][k - 1] + dp[k + 1][j] + 2, dp[i][j]);
}
}
}
cout<<dp[0][s.size() - 1]<<endl;
}
return 0;
}