HDU - 2577 How to Type【C++练习题】

本文探讨了一种算法,旨在找到输入特定字符串时的最小按键次数,考虑到CapsLock和Shift键的影响。通过动态规划的方法,算法计算了在不同状态(CapsLock开启或关闭)下完成输入所需的最少操作。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

How to Type
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8215 Accepted Submission(s): 3637

Problem Description

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input

The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output

For each test case, you must output the smallest times of typing the key to finish typing this string.

Sample Input

3
Pirates
HDUacm
HDUACM

Sample Output

8
8
8

Hint

The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

Author

Dellenge

Source

HDU 2009-5 Programming Contest

Recommend

lcy

问题简述:
要求一个字符串输入,求按键盘的最少次数。有Caps Lock和Shift两种转换大小写输入的方式。思路在代码中。

贴上代码↓↓↓

#pragma warning(disable:4996)
#include<iostream>
#include <algorithm>
using namespace std;

char ch[105];
int on[105];    //打开大写  
int off[105];   //关闭大写  

int main()
{
	int i, t, len;
	cin >> t;
	while (t--)
	{
		cin >> ch;
		len = strlen(ch);
		off[0] = 0; //刚开始的没开Caps Lock  
		on[0] = 1;  //开Caps Lock的要+1  
		for (i = 0; i < len; i++)
		{
			if (ch[i] >= 'a' && ch[i] <= 'z')    //小写字母  
			{
				//开:(开~~shift+type, 关~~type+Caps Lock)  
				on[i + 1] = min(on[i] + 2, off[i] + 2);
				//关:(开~~lock+type, 关~~type)  
				off[i + 1] = min(on[i] + 2, off[i] + 1);
			}
			else    //大写字母  
			{
				//开:(开~~type, 关~~开灯+type)  
				on[i + 1] = min(on[i] + 1, off[i] + 2);
				//关:(开~~lock+type, 关~~shift+type)  
				off[i + 1] = min(on[i] + 2, off[i] + 2);
			}
		}
		on[len]++;
		cout<< min(on[len], off[len])<<endl;
	}

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值