A+B for Input-Output Practice (VIII)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 208306 Accepted Submission(s): 61377
Problem Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
Sample Output
10
15
6
Author
lcy
Recommend
JGShining
问题链接:
http://acm.hdu.edu.cn/showproblem.php?pid=1096
问题简述:
n个数相加
贴上代码↓↓↓
#include <iostream>
using namespace std;
void main()
{
int n;
while (cin >>n)
{
for (int i = 0; i < n; i++)
{
int a,b,s=0;
cin >> a;
for (int j = 0; j < a; j++)
{
cin >> b;
s += b;
}
if (i!=n-1)cout << s << endl << endl;
else cout << s << endl;
}
}
}