ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark theroom he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster'slabyrinth.But when you arrive at the gate of the maze, the monste say :" Ihave heard that you are very clever, but if can't solve my problems, you willdie with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and aword "FIFO" or "FILO".(you are very happy because you know"FIFO" stands for "First In First Out", and"FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (Mrepresent a integer).
and the answer of a problem is a passowrd of a door, so if you want torescue ACboy, answer the problem carefully!
Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
Output
For each command "OUT", you should output ainteger depend on the word is "FIFO" or "FILO", or a word"None" if you don't have any integer.
Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT
Sample Output
1
2
2
1
1
2
None
2
3
思路:
“FIFO”(First In First Out)就是队列,“FILO”(First In Last Out) 就是栈。使用STL的stack和queue直接进行模拟即可。
代码如下:
#include<iostream>
#include<stack>
#include<queue>
using namespace std;
int main()
{
int T; char a[] = "FIFO";
cin >> T;
while (T--)
{
stack<int>Zhan;
queue<int>Dui;
int CISHU; char sign[50];
cin >> CISHU >> sign;
if (strcmp(sign, a) == 0)
{
int m; char b[50];
for (int i = 1; i <= CISHU; i++)
{
cin >> b;
if (strlen(b) == 2)
{
cin >> m;
Dui.push(m);
}
else
{
if (!Dui.empty())
{
cout << Dui.front() << endl;
Dui.pop();
}
else cout << "None" << endl;
}
}
}
else
{ int m; char b[50];
for (int i = 1; i <= CISHU; i++)
{
cin >> b;
if (strlen(b) == 2)
{
cin >> m;
Zhan.push(m);
}
else
{
if (!Zhan.empty())
{
cout << Zhan.top() << endl;
Zhan.pop();
}
else cout << "None" << endl;
}
}
}
}
return 0;
}