POJ-1363

There is a famous railway station in PopPush City. Country thereis incredibly hilly. The station was built in last century. Unfortunately,funds were extremely limited that time. It was possible to establish only asurface track. Moreover, it turned out that the station could be only adead-end one (see picture) and due to lack of available space it could haveonly one track. 


      

The localtradition is that every train arriving from the direction A continues in thedirection B with coaches reorganized in some way. Assume that the trainarriving from the direction A has N <= 1000 coaches numbered in increasingorder 1, 2, ..., N. The chief for train reorganizations must know whether it ispossible to marshal coaches continuing in the direction B so that their orderwill be a1, a2, ..., aN. Help him and write a program that decides whether itis possible to get the required order of coaches. You can assume that singlecoaches can be disconnected from the train before they enter the station andthat they can move themselves until they are on the track in the direction B.You can also suppose that at any time there can be located as many coaches asnecessary in the station. But once a coach has entered the station it cannotreturn to the track in the direction A and also once it has left the station inthe direction B it cannot return back to the station.


Input

The input consists of blocks of lines. Each block exceptthe last describes one train and possibly more requirements for itsreorganization. In the first line of the block there is the integer N describedabove. In each of the next lines of the block there is a permutation of 1, 2,..., N. The last line of the block contains just 0. 

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lineswith permutations in the input. A line of the output contains Yes if it ispossible to marshal the coaches in the order required on the corresponding lineof the input. Otherwise it contains No. In addition, there is one empty lineafter the lines corresponding to one block of the input. There is no line inthe output corresponding to the last ``null'' block of the input.

Sample Input

5

1 2 3 4 5

5 4 1 2 3

0

6

6 5 4 3 2 1

0

0

Sample Output

Yes

No

 

Yes


题意:

某城市有一个火车站,铁轨铺设如图所示。有n节车厢从A方向驶入车站,按进站顺序编号为1~n。你的任务判断是否让它们按照某种特定的顺序进入B方向的铁轨并驶出车站。例如,出站顺序(5 4 1 2 3)是不可能的,但(5 4 3 2 1)是可能的。

为了重组车厢,你可以借助中转站C。在任意时刻,只有两种选择:A到C和C到B。

在中转站C中,车厢符合后进先出的原则,因此是一个栈。


代码如下:

#include<iostream>
#include<stack>
#include<cstring>
using namespace std;
int n, target[1005];
int main()
{
	while (cin>>n&&n)
	{
		while (cin>>target[1]&&target[1])
		{
			stack<int>s;
			for (int i = 2; i <= n; i++)cin >> target[i];
			int A = 1, B = 1,ok=1;
			while (B<=n)
			{
				if (A == target[1]){ A++, B++; }
				else if (!s.empty() && s.top() == target[B])
				{
					s.pop(); B++;
				}
				else if (A <= n)s.push(A++);
				else {
					ok = 0; break;
				}
			}
			if (ok)cout << "Yes" << endl;
			else cout << "No" << endl;
		}
		cout << endl;
	}
	return 0;
}




评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值