Given a stringcontaining only 'A' - 'Z', we could encode it using the following method:
1. Each sub-string containing k same characters should be encoded to"kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.
Input
The first linecontains an integer N (1 <= N <= 100) which indicates the number of testcases. The next N lines contain N strings. Each string consists of only 'A' -'Z' and the length is less than 10000.
Output
For each testcase, output the encoded string in a line.
Sample Input
2
ABC
ABBCCC
Sample Output
ABC
A2B3C
简单题,直接输出就行。
代码如下:
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
using namespace std;
#define MAXN 10000+10
char str[MAXN];
char ans[MAXN];
int main()
{
int T; cin >> T; getchar();
while (T--)
{
memset(str, 0, sizeof(str));
gets(str);
int k = strlen(str);int count = 1;
for (int i = 0; i < k; i++)
{
if (str[i] == str[i + 1])
{
count++;
}
else
{
if (count == 1)cout << str[i];
else cout << count << str[i];
count = 1;
}
}
cout << endl;
}
return 0;
}