Given three integers A, B and C in [−263,263], you are supposed to tell whether A+B>C.
Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line Case #X: true
if A+B>C, or Case #X: false
otherwise, where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
题意:给出三个64位的数字,让你判断 a+b与c的大小关系
思路:使用long long 类型存储数字。a+b的结果一定要存储在一个long long类型的变量中,不能直接用a+b与c比较大小。
注意边界,若a>0,b>0且a+b<=0则说明越界了,反之也是。
参考代码:
#include<cstdio>
using namespace std;
int main()
{
int n;
long long a,b,c,d;
scanf("%d",&n);
for(int i=1;i<=n;i++){
scanf("%lld %lld %lld",&a,&b,&c);
d=a+b;
if(a>0&&b>0&&d<=0)
printf("Case #%d: true\n",i);
else if (a<0&&b<0&&d>=0)
printf("Case #%d: false\n",i);
else if(d>c)
printf("Case #%d: true\n",i);
else
printf("Case #%d: false\n",i);
}
return 0;
}