Wolf and Rabbit(最大公约数)

Description

There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input

    
    
2 1 2 2 2
 

Sample Output

    
    
NO YES

解题思路:

题目大意是给n个洞,收尾相接,标号为0 ~ n - 1,狼从第0个洞开始每m个洞走一步,可能有些洞永远无法走到,兔子藏在其中一个洞中,问是否安全。

这题列一下方程就很明显,将设狼走了s步,兔子藏在编号为a的洞中,则m * s - a = k * n。移项后:m * s + k * n = a。要使s和k为整数则a能被m和n的最大公约数整除。

而a是不确定的,所以只有最大公约数为1才行。

AC代码:

#include <iostream>
#include <cstdio>
using namespace std;
int Gcd(int a, int b)
{
    return b ? Gcd(b, a % b) : a;
}
int main()
{
    int p, m, n;
    scanf("%d", &p);
    while(p--)
    {
        scanf("%d%d", &m, &n);
        if(Gcd(m, n) == 1)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值