Dropping Balls
A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf nodes of FBT. To determine a ball's moving direction a flag is set up in every non-terminal node with two values, eitherfalse or true. Initially, all of the flags are false. When visiting a non-terminal node if the flag's current value at this node is false, then the ball will first switch this flag's value, i.e., from thefalse to the true, and then follow the left subtree of this node to keep moving down. Otherwise, it will also switch this flag's value, i.e., from the true to the false, but will follow the right subtree of this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at 1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered from left to right.
For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set to be false, the first ball being dropped will switch flag's values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being dropped will switch flag's values at node 1, node 3, and node 6, and stop at position 12. Obviously, the third ball being dropped will switch flag's values at node 1, node 2, and node 5 before it stops at position 10.

Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.
Now consider a number of test cases where two values will be given for each test. The first value is D, the maximum depth of FBT, and the second one is I, the Ith ball being dropped. You may assume the value of Iwill not exceed the total number of leaf nodes for the given FBT.
Please write a program to determine the stop position P for each test case.
For each test cases the range of two parameters D and I is as below:

Input
Contains l +2 lines.Line 1 I the number of test cases Line 2test case #1, two decimal numbers that are separatedby one blank ... Line k+1
test case #k Line l+1
test case #l Line l+2 -1 a constant -1 representing the end of the input file
Output
Contains l lines.Line 1 the stop position P for the test case #1 ... Line k the stop position P for the test case #k ... Line l the stop position P for the test case #l
Sample Input
5 4 2 3 4 10 1 2 2 8 128 -1
Sample Output
12 7 512 3 255
天,为什么UVa上的题目都这么长,本来挺简单的事弄得好复杂。
题意:给你一个深度为D的二叉树,让一个小球从根节点往下落,每个节点都有一个开关,初始全部关闭,没有一次小球落到节点上,他的状态都会改变,当小球达到一个节点是,若为关闭则往左走,否则往右走,问你第N个球会落到哪个节点上。
思路:判断这个球是第几个落到这个节点上的,如果为奇数个就往左走,偶数个往右走。
AC代码如下:
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{ int t,i,j,k,m,n;
while(~scanf("%d",&t) && t>0)
while(t--)
{ scanf("%d%d",&n,&m);
k=1;
for(i=1;i<n;i++)
if(m%2==1)
{ k=k*2;
m=(m+1)/2;
}
else
{ k=k*2+1;
m=m/2;
}
printf("%d\n",k);
}
}