POJ1704 Georgia and Bob(Nim问题)

题目链接:http://poj.org/problem?id=1704


Georgia and Bob
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7832 Accepted: 2415

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

题意:如图中所示,直线棋盘上有n个棋子,棋子i在第pi个格子上,两个人轮流选择一个棋子向左移动,可以移动一格或以上,不能超过前面的棋子,也不能放在已经有棋子的格子上,无法进行移动的人失败。Georiga先动,问谁会获胜。


这道题看起来有点奇怪,但仔细想一想就会发现其实就是NIm问题。两个棋子之间的距离就可以看作是NIm问题中的石子个数,右边的棋子向左移动就相当于取走石子,左边的棋子向左移动虽然相当于增加石子与NIm不符合,但是仔细考虑可以发现,虽然现在增加了,但右边棋子左移的过程中可以去掉这一部分的增加,所以总体还是一个NIm问题。


根据棋子奇偶性的不同可以分成两种情况。如果有偶数个棋子,那么Nim的石子堆就相当于每两个棋子之间的距离;如果有奇数个棋子,那么第一个棋子可以和最左边的坐标0点构成一个石子堆,剩下的在两两匹配即可。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;

int n;
int p[1005];

int main()
{
	int T;
	scanf("%d",&T);
	while (T--)
	{
		scanf("%d",&n);
		for (int i=0;i<n;i++)
		{
			scanf("%d",&p[i]);
		}
		if (n&1) p[n++]=0;//是奇数个的情况增加一个0作为最左
		sort(p,p+n);
		int ans=0;
		for (int i=0;i<n-1;i+=2)
		{
			ans^=(p[i+1]-p[i]-1);
		}
		if (ans==0) printf("Bob will win\n");
		else printf("Georgia will win\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值