#2 解方程
Total Submission(s): 284 Accepted Submission(s): 78
Misaki's Kiss again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 284 Accepted Submission(s): 78
Problem Description
After the Ferries Wheel, many friends hope to receive the Misaki's kiss again,so Misaki numbers them
1,2...N−1,N
,if someone's number is M and satisfied the
GCD(N,M)
equals to
N
XOR
M
,he will be kissed again.
Please help Misaki to find all M(1<=M<=N) .
Note that:
GCD(a,b) means the greatest common divisor of a and b .
A XOR B means A exclusive or B
Please help Misaki to find all M(1<=M<=N) .
Note that:
GCD(a,b) means the greatest common divisor of a and b .
A XOR B means A exclusive or B
Input
There are multiple test cases.
For each testcase, contains a integets N(0<N<=1010)
For each testcase, contains a integets N(0<N<=1010)
Output
For each test case,
first line output Case #X:,
second line output k means the number of friends will get a kiss.
third line contains k number mean the friends' number, sort them in ascending and separated by a space between two numbers
first line output Case #X:,
second line output k means the number of friends will get a kiss.
third line contains k number mean the friends' number, sort them in ascending and separated by a space between two numbers
Sample Input
3 5 15
Sample Output
Case #1: 1 2 Case #2: 1 4 Case #3: 3 10 12 14HintIn the third sample, gcd(15,10)=5 and (15 xor 10)=5, gcd(15,12)=3 and (15 xor 12)=3,gcd(15,14)=1 and (15 xor 14)=1
Source
Valentine's Day Round
gcd(N,x) = N ^ x;
gcd(N,x) 的结果肯定是N的约数。不妨设为k 那么 k = N^x; k和x都是已知。 。。。 然后解方程两边 k^N = N^x^N = x;
所以x = N ^ (N的约数) 这个是x的必要条件。。。
因为N的约数不一定是gcd(N,x);
注意点:long long
重复
#include <cstring>
#include <stdio.h>
#include <string>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long LL;
LL n;
LL gcd(LL x,LL y)
{
if(y == 0)
return x;
return gcd(y,x % y);
}
LL arr[100010];
LL arrnums;
LL nums;
int main()
{
LL Case = 1;
freopen("1.txt","r",stdin);
while(scanf("%I64d",&n) != EOF)
{
memset(arr,0,sizeof(arr));
arrnums = nums = 0;
LL sq = sqrt((double) n);
for(LL i=1; i<=sq; i++)
{
if(n % i == 0)
{
LL x = (i^n);
// if(x == 0) continue;
if(1 <= x && x <= n && (n ^ x) == gcd(n,x))
{
arr[arrnums++] = x;
}
LL j = n / i;
x = (j ^ n);
// if(x == 0) continue;
if(1 <= x && x <= n &&(n ^ x) == gcd(n,x))
{
arr[arrnums++] = x;
}
}
}
sort(arr,arr+arrnums);
for(LL i=0; i<arrnums; i++)
{
if(i == 0 || arr[i] != arr[i-1])
{
arr[nums++] = arr[i];
}
}
printf("Case #%I64d:\n",Case++);
printf("%I64d\n",nums);
for(int i=0; i<nums; i++)
{
printf("%I64d",arr[i]);
if(i != nums -1) printf(" ");
}
printf("\n");
}
}
gcd(N,x) = N ^ x;
gcd(N,x) 的结果肯定是N的约数。不妨设为k 那么 k = N^x; k和x都是已知。 。。。 然后解方程两边 k^N = N^x^N = x;
所以x = N ^ (N的约数) 这个是x的必要条件。。。
因为N的约数不一定是gcd(N,x);
注意点:long long
重复
#include <cstring>
#include <stdio.h>
#include <string>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long LL;
LL n;
LL gcd(LL x,LL y)
{
if(y == 0)
return x;
return gcd(y,x % y);
}
LL arr[100010];
LL arrnums;
LL nums;
int main()
{
LL Case = 1;
freopen("1.txt","r",stdin);
while(scanf("%I64d",&n) != EOF)
{
memset(arr,0,sizeof(arr));
arrnums = nums = 0;
LL sq = sqrt((double) n);
for(LL i=1; i<=sq; i++)
{
if(n % i == 0)
{
LL x = (i^n);
// if(x == 0) continue;
if(1 <= x && x <= n && (n ^ x) == gcd(n,x))
{
arr[arrnums++] = x;
}
LL j = n / i;
x = (j ^ n);
// if(x == 0) continue;
if(1 <= x && x <= n &&(n ^ x) == gcd(n,x))
{
arr[arrnums++] = x;
}
}
}
sort(arr,arr+arrnums);
for(LL i=0; i<arrnums; i++)
{
if(i == 0 || arr[i] != arr[i-1])
{
arr[nums++] = arr[i];
}
}
printf("Case #%I64d:\n",Case++);
printf("%I64d\n",nums);
for(int i=0; i<nums; i++)
{
printf("%I64d",arr[i]);
if(i != nums -1) printf(" ");
}
printf("\n");
}
}