Description
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed
Input
Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)
Output
For each line of input, your program should print a numble on a line,according to the above rules
Sample Input
4 2
5 7
123 123
Sample Output
5
0
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed
Input
Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)
Output
For each line of input, your program should print a numble on a line,according to the above rules
Sample Input
4 2
5 7
123 123
Sample Output
5
0
8
我只想说平时不切题,赛时徒伤悲!!!
可以说这是一个公式,注意n=1的情况。
#include<stdio.h>
int main()
{
int n,m,i;
while(scanf("%d%d",&n,&m)!=EOF)
{
int ans,a=10,k;
if(n==1)
printf("0\n");
for(i=0;i<m;i++)
{
ans=a/n;
k=a%n;
a=k*10;
}
printf("%d\n",ans);
}
return 0;
}