Digital Roots

题目1124:Digital Roots

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:901

解决:337

题目描述:

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

输入:

    The input file will contain a list of positive integers, one per line. 
    The end of the input will be indicated by an integer value of zero.

输出:

    For each integer in the input, output its digital root on a separate line of the output.

样例输入:
24
39
0
样例输出:
6
3
提示:

The integer may consist of a large number of digits.

import java.util.*;
import java.math.*;
public class Main{
    public static void main(String args[]){
        Scanner cin=new Scanner(System.in);
        BigInteger a;
        while(cin.hasNext()){
            a=cin.nextBigInteger();
            if(a.equals(BigInteger.ZERO)) break;
            System.out.println(Result(a));
        }
    }
    static BigInteger Result(BigInteger n){
        BigInteger result=BigInteger.ZERO;
        while(n.compareTo(BigInteger.ZERO)==1){
            result=result.add(n.mod(BigInteger.TEN));
            n=n.divide(BigInteger.TEN);
        }
        if(result.compareTo(BigInteger.TEN)>-1) return Result(result);
        return result;
    }
}
 
/**************************************************************
    Problem: 1124
    User: 3011216016
    Language: Java
    Result: Accepted
    Time:740 ms
    Memory:59512 kb
****************************************************************/



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值