hdoj 1060 Leftmost Digit 幂指函数取对数

本文介绍了一种高效算法,用于求解给定正整数N的N^N结果中最左侧的数字。通过数学转换,利用对数性质减少数值计算复杂度,避免了直接计算N^N带来的巨大数值运算问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12268    Accepted Submission(s): 4689


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 



Descriptipn:    计算N^N结果的最左边的数            
How to Do:    数学题 由sum=N^N,两边对10取对数,log10(sum)=Nlog10(N),有sum=10^(Nlog10(N));
           由于10的整数次幂首位均为1,则仅需考虑Nlog10(N)的结果的小数部分即可
 

易错点: 1、数值太大,类型需要用long long.

           2、对数函数的调用。


代码:

#include <iostream>
#include <stdio.h>
#include <math.h>

using namespace std;

int main()
{
    long long t,n;
    long long x,m;
    double m1;
    cin>>t;
    while(t--)
    {
        cin>>n;
        m1=n*log10(double(n));
        x=(long long)(m1);
        m1-=x;
        m=(long long)(pow(10.0,m1));
        cout<<m<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值