hdu(数值计算 概率)

                                                    Candy

                                 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Problem Description
LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
 

Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 10 5) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10 -4 would be accepted.
 

Sample Input
  
  
10 0.400000 100 0.500000 124 0.432650 325 0.325100 532 0.487520 2276 0.720000
 

Sample Output
  
  
Case 1: 3.528175 Case 2: 10.326044 Case 3: 28.861945 Case 4: 167.965476 Case 5: 32.601816 Case 6: 1390.500000
 
本题题意是给你两个罐子,每个里面都有n个糖,现在LazyChild每天要随机从一个里面拿出一个糖,且选择其中一个罐子的概率为p,问当他某天打开罐子时发现里面没有糖了,问另外一个罐子中糖果数的期望。
求出期望值为:
                 (晕啊,发现打出这个式子比求出这个式子还难,汗碎了一键盘啊)
思路:  刚开始的时候想直接求p的n+1次方和q的n+1次方,后来发现测试数组有问题,因为一旦n的值过大后,肯定会出现下溢的,后来发现,反正p 和 q 都是乘进去的,可以在0到n-1循环中一次次的乘进去的,然后还有:
C(n+k,k)=C(n+k-1,k-1)*(n+k)/k;所以C(n+k,k)*p^(n+1)*q^k=C(n+k-1,k-1)*p^(n+1)*q^(k-1)*(n+k-1)/(k-1)*q;
代码:
#include<iostream>
#include<cstdio>
using namespace std;

double sove(int n,double p)
{
    double ans1,ans2,temp=1.000000;
    ans2=n*(1-p);ans1=n*p;//k=0的情况
    for(int k=1;k<=n;k++)//按理说k是小于n的,但这样方便求p和q的n+1次方
    {
        temp = temp*(n+k)*p*(1-p)/k;
        ans1 += temp*(n-k);//而且k=n后ans1和ans2在此处的值也不会改变
        ans2 += temp*(n-k);
        ans1 *= p;
        ans2 *= (1-p);
    }
    return ans1+ans2;
}

int main()
{
    int n;double p;
    int case1=1;
    while(~scanf("%d %lf",&n,&p))
    {
        double ans;
        ans=sove(n,p);
        printf("Case %d: %lf\n",case1++,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值