HDU 4489The King’s Ups and Downs(dp递推)

Description

The king has guards of all   different heights. Rather than line them up in increasing or  decreasing height order, he wants to line them up so each guard   is either shorter than the guards next to him or taller than the guards next to him (so the heights go up and  down along the line). For example, seven guards of heights 160, 162, 164, 166, 168, 170   and   172 cm. could be arranged as:


or perhaps:


The king wants to know how many guards he needs so he can have a   different up and down order at each changing of the guard for rest of his reign. To be able to do this, he needs to know for a given number of guards, n, how many  different up and  down orders there are:

For example, if there are four guards: 1, 2, 3,4 can be arrange   as:

1324, 2143, 3142, 2314, 3412, 4231, 4132, 2413, 3241, 1423

For this problem, you will write a program that takes as input a positive integer n, the number of guards and returns the number of up and down orders for n guards of   differing heights.
 

Input

The first line of input contains a single integer P, (1 <= P <= 1000), which is the number of  data sets that follow.  Each  data set consists of single line of input containing two integers.  The first integer, D is the   data set number.  The second  integer, n (1 <= n <= 20), is the number of guards of   differing heights.
 

Output

For each   data set there is one line of output.  It contains the   data set number (D) followed  by a single space, followed by the number of up and down orders for the n guards.
 

Sample Input

41 12 33 44 20

 

Sample Output

    
    
1 1 2 4 3 10 4 740742376475050
 
      解析:
 
代码:
#include <iostream>
#include <cstring>
#include<cstdio>
using namespace std;
__int64 dp[25][2],c[25][25],ans;

int main()
{
    int i,j,p,t,k;
    for(i=1;i<21;i++)
    {
        c[i][0]=c[i][i]=1;
         for(j=1;j<i;j++)
         {
            c[i][j]=c[i-1][j]+c[i-1][j-1];
//            cout<<"c["<<i<<"]["<<j<<"]"<<c[i][j]<<endl;
         }
    }
    dp[0][0]=1;dp[0][1]=1;
    dp[1][0]=1;dp[1][1]=1;
    for(i=2;i<21;i++)
    {
        ans = 0;
        for(j=0;j<i;j++)
            ans += (dp[j][0] * dp[i-j-1][1] * c[i-1][j]);
        dp[i][0]=dp[i][1]=ans/2;
 //        cout<<"dp["<<i<<"][1]"<<dp[i][1]*2<<endl;
    }
    scanf("%d",&p);
    while(p--)
    {
        scanf("%d %d",&t,&k);
        if(k==1)
            printf("%d 1\n",t);
        else
            printf("%d %I64d\n",t,dp[k][0]<<1);
    }
    return 0;
}
/*
打表
#include <iostream>
#include <cstring>
#include<cstdio>
using namespace std;
__int64 ans[21]={
    0,1,2,4,10,32,122,544,2770,15872,101042,707584,5405530,44736512,398721962,
    3807514624ll,38783024290ll,419730685952ll,4809759350882ll,58177770225664ll,
    740742376475050ll};

int main()
{
    int p,t,k;
    scanf("%d",&p);
    while(p--)
    {
        scanf("%d %d",&t,&k);
        printf("%d %I64d\n",t,ans[k]);
    }
    return 0;
}
*/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值