DNA Sorting(OpenJ_Bailian - 1007)

博客围绕DNA字符串排序问题展开,介绍了衡量序列“无序度”的逆序数概念。要求对DNA字符串按“有序度”从高到低排序,给出了输入输出格式及示例,还提示解题思路是统计每排字母逆序数并排序,最后给出代码。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

B - DNA Sorting

来源: OpenJ_Bailian - 1007 

Time limit:1000 ms           Memory limit:65536 kB

OS:Linux                          Source:East Central North America 1998

Problem Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Hint:题目要求就是找出每一排中,每一个字母后边比它大的(ASC码或者字母序)字母的数目,然后每一排中所有字母之和。然后将每一排按从小到大排序;题目并不难,开始以为会超时,应该是数据量不是很大。

代码如下:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
using namespace std;
char s[110][55];
int a[110] = {0};
void qs(int l, int r);
int main()
{
    int n, m, x, i, j, k;
    scanf("%d %d", &n, &m);
    for(i = 0; i < m; i++)
    {
        scanf("%s", s[i]);
        for(j = 0; j < n; j++)
        {
            x = 0;
            for(k = j + 1; k < n; k++)
            {
                if(s[i][j] > s[i][k])
                {
                    x++;
                }
            }
            a[i] += x;
        }
    }
    qs(0, m - 1);
    for(i = 0; i < m; i++)
    {
        printf("%s\n", s[i]);
    }
    return 0;
}
void qs(int l, int r)
{
    if(l >= r) return ;
    int i = l, j = r, x = a[l];
    char key[55];
    strcpy(key, s[l]); //快排,将大小快排的同时也将每一排换掉(没有用到结构体)
    while(i < j)
    {
        while(i < j && a[j] >= x)
        {
            j--;
        }
        a[i] = a[j];
        strcpy(s[i], s[j]);
        while(i < j && a[i] <= x)
        {
            i++;
        }
        a[j] = a[i];
        strcpy(s[j], s[i]);
    }
    a[i] = x;
    strcpy(s[i], key);
    qs(l, i - 1);
    qs(i + 1, r);
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

WMYBlog

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值