B - DNA Sorting
Time limit:1000 ms Memory limit:65536 kB
OS:Linux Source:East Central North America 1998
Problem Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT
Sample Output
CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA
Hint:题目要求就是找出每一排中,每一个字母后边比它大的(ASC码或者字母序)字母的数目,然后每一排中所有字母之和。然后将每一排按从小到大排序;题目并不难,开始以为会超时,应该是数据量不是很大。
代码如下:
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
using namespace std;
char s[110][55];
int a[110] = {0};
void qs(int l, int r);
int main()
{
int n, m, x, i, j, k;
scanf("%d %d", &n, &m);
for(i = 0; i < m; i++)
{
scanf("%s", s[i]);
for(j = 0; j < n; j++)
{
x = 0;
for(k = j + 1; k < n; k++)
{
if(s[i][j] > s[i][k])
{
x++;
}
}
a[i] += x;
}
}
qs(0, m - 1);
for(i = 0; i < m; i++)
{
printf("%s\n", s[i]);
}
return 0;
}
void qs(int l, int r)
{
if(l >= r) return ;
int i = l, j = r, x = a[l];
char key[55];
strcpy(key, s[l]); //快排,将大小快排的同时也将每一排换掉(没有用到结构体)
while(i < j)
{
while(i < j && a[j] >= x)
{
j--;
}
a[i] = a[j];
strcpy(s[i], s[j]);
while(i < j && a[i] <= x)
{
i++;
}
a[j] = a[i];
strcpy(s[j], s[i]);
}
a[i] = x;
strcpy(s[i], key);
qs(l, i - 1);
qs(i + 1, r);
}