PAT_1072

本文深入探讨了深度学习技术在音视频处理领域的应用,涵盖了从图像处理到AR特效,再到AI音视频处理等多个方面,展示了深度学习如何通过神经网络实现复杂任务的自动化处理。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1072. Gas Station (30)

时间限制
200 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2
Sample Output 1:
G1
2.0 3.3
Sample Input 2:
2 1 2 10
1 G1 9
2 G1 20
Sample Output 2:
No Solution
 
 
#include <string>
#include <iostream>
#include <sstream>
#include <iomanip>
using namespace std;
const int max_num = 9999999;
int **dist;
int *shortestpath;
int max_range;
int N,M;

bool dijkstra(int start) {
	bool *visited=new bool[N+M+1]; 
	for (int i = 0; i <= N + M; ++ i) {
		visited[i] = 0;
		shortestpath[i] = max_num;
	}

	shortestpath[start] = 0;
	while (true) {
		int cur_vertex = -1;
		int min = max_num;
		for (int i = 1; i <= N+M; ++ i) {
			if (!visited[i] && shortestpath[i] < min) {
				min = shortestpath[i];
				cur_vertex = i;
			}
		}
		if (cur_vertex == -1)
			break;

		visited[cur_vertex] = 1;

		for (int i = 1; i <= M+N; ++ i) {
			if (dist[cur_vertex][i] != 0 && i != cur_vertex) {
				if (shortestpath[cur_vertex] + dist[cur_vertex][i] < shortestpath[i]) {
					shortestpath[i] = shortestpath[cur_vertex] + dist[cur_vertex][i];
				}
			}
		}
	}
	return true;
}


bool dij(int N, int source){
	bool *visit = new bool[N];
	for(int i = 1; i < N; ++i){
		visit[i] = false;
		shortestpath[i] = max_num;
/*
		if(dist[source][i] != max_num)
			shortestpath[i] = dist[source][i];
		else
			shortestpath[i] = max_num;*/
	}
	shortestpath[source] = 0;

	int tempsource = source;
	for(int i = 1; i < N; ++i){
		int tempmin = max_num;
		for(int j = 1; j < N; ++j)
			if(visit[j] == false && shortestpath[j] < tempmin){
					tempmin = shortestpath[j];
					tempsource = j;
			}
			visit[tempsource] = true;
			if(shortestpath[tempsource] > max_range)
				return false;
			for(int j =1; j < N; ++j){
				if(dist[tempsource][j] != max_num && visit[j] == false) {
					int newdistance = shortestpath[tempsource] + dist[tempsource][j];
					if(newdistance < shortestpath[j])
						shortestpath[j] = newdistance;
				}
			}
	}
	return true;
}
int main(){
	std::ios::sync_with_stdio(false);
	int K,D;
	cin>>N>>M>>K>>D;
	max_range = D;
	dist = new int*[N+M+1];
	shortestpath = new int[N+M+1];
	for(int i = 0; i < N+M+1; ++i)
		dist[i] = new int[N+M+1];

	for(int i =0; i< N+M+1; ++i)
		for(int j = 0; j < N+M+1; ++j)
			dist[i][j] = max_num;

	for(int i = 1; i <= K; ++i){
		string s1, s2, d;
		int x,y,l;
		cin>>s1>>s2>>d;
		stringstream ss;
		if(*s1.begin() == 'G')
			x = atoi((s1.substr(1,s1.size()-1)).c_str())+N;
		else
			x = atoi(s1.c_str());
		if(*s2.begin() == 'G')
			y = atoi((s2.substr(1,s2.size()-1)).c_str())+N;
		else
			y = atoi(s2.c_str());
		l = atoi(d.c_str());
		dist[x][y] = dist[y][x] = l;
	}
	int local_maxofmin = -max_num;
	int local_sum = max_num;
	int best;
	bool find = false;
	for(int i = N+1; i <= N+M; ++i){
		dij(N+M+1,i);
		//dijkstra(i);
		int min = max_num;
		int sum = 0;
		for (int j = 1; j <= N; ++ j) {
			sum += shortestpath[j];
			if (shortestpath[j] > max_range) {
				sum = 0;
				break;
			}
			if (shortestpath[j] < min) {
				min = shortestpath[j];
			}
		}

		if (sum != 0 && ((min > local_maxofmin) || (min == local_maxofmin && sum < local_sum))) {
			local_sum = sum;
			local_maxofmin = min;
			best = i ;
			find = true;
		}
	}
	cout<<fixed<<setprecision(1);
	if(find == false)
		cout<<"No Solution";
	else{
		best = best - N;
		stringstream ss;
		ss << best;
		string str = ss.str();
		str ="G"+str;
		cout<<str<<endl;
		cout<<local_maxofmin/1.0<<" "<<local_sum/(1.0*N);
	}

	return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值