Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 11340 | Accepted: 3832 |
Description
Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.
Each cow i has a specified height hi (1 ≤ hi≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cowi can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cowi.
Consider this example:
= = = = - = Cows facing right --> = = = = - = = = = = = = = = 1 2 3 4 5 6
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!
Let ci denote the number of cows whose hairstyle is visible from cowi; please compute the sum ofc1 throughcN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.
Input
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Sample Input
6 10 3 7 4 12 2
Sample Output
5
Source
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
long long int stack[80005],t;
int main()
{
int n,i,top=-1;
unsigned long ans = 0;
while(scanf("%d",&n)!=EOF && n!=0)
{
memset(stack,'0',sizeof(stack));
top = -1;ans = 0;
for(i=0;i<n;i++)
{
scanf("%lld",&t);
if(top == -1)stack[++top]=t;
else
{
while(top >= 0 && stack[top]<=t)top--;
stack[++top] = t;
ans += top;
}
}
printf("%lu\n",ans);
}
return 0;
}