Falling Leaves
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 3588 | Accepted: 2005 |
Description

Figure 1
Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem.
A binary tree of letters may be one of two things:
- It may be empty.
- It may have a root node. A node has a letter as data and refers to a left and a right subtree. The left and right subtrees are also binary trees of letters.
In the graphical representation of a binary tree of letters:
- Empty trees are omitted completely.
- Each node is indicated by
- Its letter data,
- A line segment down to the left to the left subtree, if the left subtree is nonempty,
- A line segment down to the right to the right subtree, if the right subtree is nonempty.
- Its letter data,
A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y.
The preorder traversal of a tree of letters satisfies the defining properties:
- If the tree is empty, then the preorder traversal is empty.
- If the tree is not empty, then the preorder traversal consists of the following, in order
- The data from the root node,
- The preorder traversal of the root's left subtree,
- The preorder traversal of the root's right subtree.
- The data from the root node,
The preorder traversal of the tree in Figure 1 is KGCBDHQMPY.
A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies:
The root's data comes later in the alphabet than all the data in the nodes in the left subtree.
The root's data comes earlier in the alphabet than all the data in the nodes in the right subtree.
The problem:
Consider the following sequence of operations on a binary search tree of letters
Remove the leaves and list the data removed
Repeat this procedure until the tree is empty
Starting from the tree below on the left, we produce the sequence of trees shown, and then the empty tree

by removing the leaves with data
BDHPY
CM
GQ
K
Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree.
Input
The input will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters.
The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk ('*').
The last data set is followed by a line containing only a dollar sign ('$'). There are no blanks or empty lines in the input.
The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk ('*').
The last data set is followed by a line containing only a dollar sign ('$'). There are no blanks or empty lines in the input.
Output
For each input data set, there is a unique binary search tree that would produce the sequence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.
Sample Input
BDHPY CM GQ K * AC B $
Sample Output
KGCBDHQMPY BAC
Source
/*
题意:给一颗二叉搜索树,仿佛掉树叶一样,每次去掉它的所有叶子节点,分层输入,要求输出原来二叉树的先序遍历顺序。
分析:按照输入,重新建成原树,用先序方式输出。
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
struct node
{
char c;
int light_child;//左右支数的个数
int right_child;
}num[30];
int N;
char str[30][27];
void add(int t,char c)//重新建树,比根节点小的放到左边,比跟节点大的放到右边。
{
if(c<num[t].c)
{
if(num[t].light_child==0)//树枝里没有数据,直接加上
{
num[N].c=c;
num[t].light_child=N++;
return ;
}
else add(num[t].light_child,c);//否则进到下一层树枝里进行判断。
}
else
{
if(num[t].right_child==0)
{
num[N].c=c;
num[t].right_child=N++;
return ;
}
else add(num[t].right_child,c);
}
}
void print(int t)
{//输出顺序为先根遍历方式。此处可以改动适应三种输出方式
printf("%c",num[t].c);
if(num[t].light_child)print(num[t].light_child);
if(num[t].right_child)print(num[t].right_child);
}
int main()
{
int i,j,count;
while (scanf("%s",str[0])!=EOF)
{
if(str[0][0]=='$')break;
memset(num,0,sizeof(num));
count=0;
while (str[count][0]>='A'&&str[count][0]<='Z')
{
scanf("%s",str[++count]);
}
count--;
N=0;
num[N++].c=str[count][0];//num[0]根节点
for (i=count-1;i>=0;i--)
{
for (j=0;j<strlen(str[i]);j++)
{
add(0,str[i][j]);
}
}
print(0);
printf("\n");
}
return 0;
}