POJ 2955 Brackets



POJ 2955 ;链接:http://poj.org/problem?id=2955

题目:

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2463 Accepted: 1267

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence ofs. That is, you wish to find the largestm such that for indicesi1,i2, …,im where 1 ≤i1 <i2 < … <imn, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is[([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters(,), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6
 
 
解题思路:
这道题目和POJ 1141有点相像。可以使用dp来做,用dp[i][j]表示,原序列的从i位置到j位置的子序列。当s[i]和s[j]匹配时,dp[i][j] = max(dp[i+1][j-1]+1,d[i][k]+d[k+1][j])(k>=i&&k<j);否则,dp[i][j] = max(dp[i][j], d[i][k] + d[k+1][j])(k>=i && k < j);
 
 
代码:
#include <iostream>
#include <cstring>
using namespace std;

#define max(x,y) x>y?x:y

const int MAXN = 110;
int dp[MAXN][MAXN];
string s, t;

int main()
{
	std::ios::sync_with_stdio(false);
	
	while(!cin.eof())
	{
		t = s = "";
		cin >> t;
		s = ' ' + t;
		
		if("end" == t) break;
		memset(dp, 0, sizeof(dp));
		int len = t.length();
		
		for(int r = 1; r < len; r++)
		{
			for(int i = 1; i <= len - r; i++)
			{
				int j = i + r;
				if(('(' == s[i] && ')' == s[j]) || ('[' == s[i] && ']' == s[j]))
				{
					dp[i][j] = dp[i+1][j-1] + 1;			
				}
				for(int k = i; k < j; k++)
				{
					if(dp[i][j] < dp[i][k] + dp[k+1][j])
						dp[i][j] = dp[i][k] + dp[k+1][j];
				}
			}
		}
		
		cout << 2 * dp[1][len] << endl;
	}
	
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值