The Tower of Babylon UVA - 437 (DAG上的动态规划变形,记忆化搜索)

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this talehave been forgotten. So now, in line with the educational nature of this contest, we will tell you thewhole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type.Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block couldbe reoriented so that any two of its three dimensions determined the dimensions of the baseand the other dimension was the height.

They wanted to construct the tallest tower possible by stacking blocks. The problem wasthat, in building a tower, one block could only be placed on top of another block as long asthe two base dimensions of the upper block were both strictly smaller than the correspondingbase dimensions of the lower block. This meant, for example, that blocks oriented to haveequal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians canbuild with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,representing the number of different blocks in the following data set. The maximum value for n is 30.Each of the next n lines contains three integers representing the values xi, yi and zi.Input is terminated by a value of zero (0) for n.


Output

For each test case, print one line containing the case number (they are numbered sequentially startingfrom 1) and the height of the tallest possible tower in the format‘

Case case: maximum height = height’

Sample Input

1

10 20 30

2

6 8 10

5 5 5

7

1 1 1

2 2 2

3 3 3

4 4 4

5 5 5

6 6 6

7 7 7

5

31 41 59

26 53 58

97 93 23

84 62 64

33 83 27

0

Sample Output

Case 1: maximum height = 40

Case 2: maximum height = 21

Case 3: maximum height = 28

Case 4: maximum height = 342

题目大意:给出n种立方体,每种立方体有无限多个,然后将立方体摞起来,条件:上面的立方体的长宽要严格小于下面的立方体,问最多可以摞多么高。

题解:对于一个立方体,如果把它的放置的方法不同那么可能会造成不同的结果,对于每一种结果最多会用一次,因为要严格小于。对于一种立方体有6种不同的放置结果,

然后建图求最长路就可以了,这是求点的价值,而不是边的,每一个点有一个价值,为它的高

这是紫书上的练习题,直接用记忆化搜索就行了

(对于这种动态规划,无非就是dfs记忆化和递推,根据状态转移方程模拟就行了)

#include <iostream>
#include <bits/stdc++.h>

using namespace std;

struct node
{
    long long x,y,z;
} q[200];

int mp[200][200];
long long dp[200];
int vis[200];
int top;
long long dfs(int s)
{
    if(vis[s])return dp[s];
    vis[s]=1;
    dp[s]=q[s].z;
    for(int i=0; i<top; i++)
    {
        if(mp[s][i])
        {
            dp[s]=max(dp[s],dfs(i)+q[s].z);
        }
    }
    return dp[s];
}
int main()
{
    int n;
    long long x,y,z;
    int w=0;
    while(scanf("%d",&n),n)
    {
        top=0;
        for(int i=0; i<n; i++)
        {
            scanf("%lld%lld%lld",&x,&y,&z);
            q[top].x=x;
            q[top].y=y;
            q[top++].z=z;

            q[top].x=y;
            q[top].y=x;
            q[top++].z=z;

            q[top].x=y;
            q[top].y=z;
            q[top++].z=x;

            q[top].x=z;
            q[top].y=y;
            q[top++].z=x;

            q[top].x=x;
            q[top].y=z;
            q[top++].z=y;

            q[top].x=z;
            q[top].y=x;
            q[top++].z=y;
        }
        //cout<<top<<endl;
        memset(mp,0,sizeof(mp));
        for(int i=0; i<top; i++)
        {
            for(int j=0; j<top; j++)
            {
                if(i==j)continue;
                if(q[i].x>q[j].x&&q[i].y>q[j].y)
                {
                    mp[i][j]=1;
                    //cout<<i<<"->"<<j<<endl;
                }
            }
        }
        long long mx=0;
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
        for(int i=0; i<top; i++)
        {
            if(!vis[i])
            {
                //dp[i]=dfs(i)+q[i].z;
                //cout<<i<<" "<<dp[i]<<" "<<q[i].z<<endl;
                mx=max(mx,dfs(i));
            }
        }
        printf("Case %d: maximum height = %lld\n",++w,mx);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值