There are NN different kinds of transport ships on the port. The i^{th}ith kind of ship can carry the weight of V[i]V[i] and the number of the i^{th}ith kind of ship is 2^{C[i]} - 12C[i]−1. How many different schemes there are if you want to use these ships to transport cargo with a total weight of SS?
It is required that each ship must be full-filled. Two schemes are considered to be the same if they use the same kinds of ships and the same number for each kind.
Input
The first line contains an integer T(1 \le T \le 20)T(1≤T≤20), which is the number of test cases.
For each test case:
The first line contains two integers: N(1 \le N \le 20), Q(1 \le Q \le 10000)N(1≤N≤20),Q(1≤Q≤10000), representing the number of kinds of ships and the number of queries.
For the next NN lines, each line contains two integers: V[i](1 \le V[i] \le 20), C[i](1 \le C[i] \le 20)V[i](1≤V[i]≤20),C[i](1≤C[i]≤20), representing the weight the i^{th}ith kind of ship can carry, and the number of the i^{th}ith kind of ship is 2^{C[i]} - 12C[i]−1.
For the next QQ lines, each line contains a single integer: S(1 \le S \le 10000)S(1≤S≤10000), representing the queried weight.
Output
For each query, output one line containing a single integer which represents the number of schemes for arranging ships. Since the answer may be very large, output the answer modulo 10000000071000000007.
样例输入复制
1 1 2 2 1 1 2
样例输出复制
0 1
题目来源
题意:有n种船,每种船负重v,数量(1<<c)-1,q次询问,每次询问s重量需要船载重的方案数。
题解:利用多重背包二进制划分的思想进行物品的捆绑分割,然后dp一下即可
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int mod=1e9+7;
const int maxn=1e6+7;
ll dp[maxn],val[maxn];
int main()
{
int t;
cin>>t;
while(t--)
{
int n,q;
scanf("%d%d",&n,&q);
int cot=0;
for(int i=0;i<n;i++)
{
ll v,c;
scanf("%lld%lld",&v,&c);
for(int j=0;j<c;j++)
val[++cot]=(1LL<<j)*v;
}
memset(dp,0,sizeof(dp));
dp[0]=1;
for(int i=1;i<=cot;i++)
for(int j=10005;j>=val[i];j--)
{
dp[j]+=dp[j-val[i]];
dp[j]%=mod;
}
while(q--)
{
int s;
scanf("%d",&s);
printf("%lld\n",dp[s]);
}
}
}