Description
A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.
Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.
Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:
cash N n1 D1 n2 D2 ... nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
cash N n1 D1 n2 D2 ... nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
Sample Output
735
630
0
0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.
In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.
In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.
In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
题意:
有各种不同面值的货币,每种面值的货币有不同的数量,然后利用这些货币去凑成最接近且小于等于给定的数字cash的金额。
分析:
n种货币容量为cash,第i种货币最多有a[i]个可用,每个费用为b[i],裸的多重背包问题。
背包九讲里有一个很好的伪代码:
procedure MultiplePack(cost,weight,amount) // amount表示物品的数量
if cost*amount>=V
CompletePack(cost,weight)
return
integer k=1
while k<num
ZeroOnePack(k*cost,k*weight)
amount=amount-k
k=k*2
ZeroOnePack(amount*cost,amount*weight)
详见背包九讲......
代码:
#include<stdio.h>
#include<string.h>
int inline MAX(int i,int j)
{
if(i>j)
return i;
return j;
}
int a[15],b[15],dp[100010];
int main()
{
int n,i,j,k,temp,cash;
while(scanf("%d%d",&cash,&n)==2)
{
memset(dp,0,sizeof(dp));
for(i=0;i<n;i++)
{
scanf("%d%d",&a[i],&b[i]);
dp[b[i]]=b[i];
}
for(i=0;i<n;i++)
{
if(b[i]*a[i]>=cash)//该物品最多超过了总容量,完全背包
{
for( j=b[i]; j<=cash;j++)//j由小变大,因为每件物品个数有无限个,可重复放入
dp[j]=MAX(dp[j],dp[ j-b[i] ]+b[i]);
}
else//多重背包
{
k=1;
temp=a[i] ;
while( k<temp )
{
for( j=cash;j>=k*b[i];j--)//j由大变小,因为后面的先改变后不会影响前面的,反之则不行!!
dp[j]=MAX(dp[j],dp[ j-b[i]*k ]+b[i]*k);
temp-=k;
k*=2;
}
for( j=cash;j>=temp* b[i];j--)
dp[j]=MAX(dp[j],dp[ j-temp*b[i]]+temp*b[ i ]);
}
}
printf("%d\n",dp[cash]);
}
return 0;
}