hdu 2639 Bone Collector II(第K优背包)

Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 231).
 

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
12 2 0
 

 

  背包问题求第K优解,在01背包的 方程上加一维,即dp[i][v][k]。

这个方程可以理解为: dp[i][v]这个有序队列是由dp[i-1][v]和dp[i-1][v-c[i]]+w[i]这两个有序队列合并得到的。有序队列dp[i-1][v]即dp[i-1][v][1..K],dp[i-1][v-c[i]]+w[i]则理解为在dp[i-1][v-c[i]][1..K]的每个数上加上w[i]后得到的有序队列。合并这两个有序队列并将结果(的前K项)储存到dp[i][v][1..K]中。


代码:

#include<stdio.h>
#include<string.h>

typedef struct node
{
	int vol, w;
}point;
point q[105];
int n, vol, k;
int dp[1005][35];
int x[35], y[35];

void zeroOnePack(point q)
{
	int a, b, c, j;
	for(int i=vol;i >=q.vol;i--)
	{
		for(j=0;j<k; j++)
		{
			x[j]=dp[i][j];
			y[j]=dp[i-q.vol][j]+q.w;
		}
		x[k]=y[k]=-1;  //结束标志
		a = b = c = 0;
		while(c<k && (a<k||b<k))
		{
			if(x[a]>y[b])
				dp[i][c]=x[a],a++;
			else
				dp[i][c]=y[b], b++;
			if(dp[i][c]!=dp[i][c-1])
				c++;
		}
	}
}

int main()
{
	int t;
	scanf("%d", &t);
	while(t--)
	{
                memset(dp, 0, sizeof(dp));
		scanf("%d %d %d", &n, &vol, &k);
		for(int i = 0; i < n; i++)
			scanf("%d", &q[i].w);
		for(int i = 0; i < n; i++)
			scanf("%d", &q[i].vol);
		for(int i = 0; i < n; i++)
			zeroOnePack(q[i]);
		printf("%d\n",dp[vol][k-1]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值