一、P - Reduced ID Numbers

P - Reduced ID Numbers

POJ - 2769

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10 6-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8

 题意:给定一些数字,让你找一个最小的数k,使得给出的数中没有任何两个数对k同余。

思路:(暴力求解)如果只有一个数,直接输出1;否则,从2开始试每个数字看看有没有同余的,如果找到同余则break,直到找到一个合适的数为止。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int maxn=1000005;
int a[305];
int b[maxn];
int main()
{
    int t,i;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        for(i=0;i<n;i++) scanf("%d",&a[i]);
        if(n==1)  printf("1\n");
        else
        {
        	int yu;
            for(yu=2;;yu++)
            {
                bool flag=0;
                memset(b,0,sizeof(int)*(yu+1));
                for(int j=0;j<n;j++)
                {
                    if(b[a[j]%yu]==1)
					{
						flag=1;
						break;
					}
					else b[a[j]%yu]++;
                }
                if(flag==0)  break;
            }
            cout<<yu<<endl;
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值