P - Reduced ID Numbers
T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10 6-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.
Input
On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.
Output
For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.
Sample Input
2 1 124866 3 124866 111111 987651
Sample Output
1 8
题意:给定一些数字,让你找一个最小的数k,使得给出的数中没有任何两个数对k同余。
思路:(暴力求解)如果只有一个数,直接输出1;否则,从2开始试每个数字看看有没有同余的,如果找到同余则break,直到找到一个合适的数为止。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1000005;
int a[305];
int b[maxn];
int main()
{
int t,i;
cin>>t;
while(t--)
{
int n;
cin>>n;
for(i=0;i<n;i++) scanf("%d",&a[i]);
if(n==1) printf("1\n");
else
{
int yu;
for(yu=2;;yu++)
{
bool flag=0;
memset(b,0,sizeof(int)*(yu+1));
for(int j=0;j<n;j++)
{
if(b[a[j]%yu]==1)
{
flag=1;
break;
}
else b[a[j]%yu]++;
}
if(flag==0) break;
}
cout<<yu<<endl;
}
}
return 0;
}