Problem Description
有M个敢死队员要炸掉敌人的一个碉堡,谁都不想去,排长决定用轮回数数的办法来决定哪个战士去执行任务。如果前一个战士没完成任务,则要再派一个战士上去。现给每个战士编一个号,大家围坐成一圈,随便从某一个战士开始计数,当数到5时,对应的战士就去执行任务,且此战士不再参加下一轮计数。如果此战士没完成任务,再从下一个战士开始数数,被数到第5时,此战士接着去执行任务。以此类推,直到任务完成为止。
这题本来就叫“敢死队”。“谁都不想去”,就这一句我觉得这个问题也只能叫“不敢死队问题”。今天大家就要完成这道不敢死队问题。我们假设排长是1号,按照上面介绍,从一号开始数,数到5的那名战士去执行任务,那么排长是第几个去执行任务的?
Input
输入包括多试数据,每行一个整数M(0<=M<=10000)(敢死队人数),若M==0,输入结束,不做处理。
Output
输出一个整数n,代表排长是第n个去执行任务。
Example Input
9
6
223
0
Example Output
2
6
132
#include <stdio.h>
#include <stdlib.h>
struct node
{
int num;
struct node *next;
};
struct node *creat(int m) //建立循环链表
{
int i;
struct node *head, *p, *tail;
p = (struct node *)malloc(sizeof(struct node));
p -> num = 1;
p -> next = NULL;
head= p;
tail = p;
for(i = 2; i <= m; i++)
{
p = (struct node *)malloc(sizeof(struct node));
p -> num = i;
p -> next = NULL;
tail -> next = p;
tail = p;
}
tail -> next = head; //最后一个结点指针指向head
return (head);
};
int sel(struct node *head, int m)
{
int n = 0, t = 0;
struct node *p, *q;
q = head;
while(q -> next != head)
{
q = q -> next;
}
while(q -> next != NULL) //也可以用计数来控制(t<m)
{
p = q -> next;
n++;
if(n % 5 == 0)
{
q -> next = p -> next;
t++;
if(p -> num == 1)
{
return t;
break;
}
free(p);
}
else
q = p;
}
}
int main()
{
int m, t;
struct node *head;
while(scanf("%d", &m) && m)
{
head = creat(m);
t = sel(head, m);
printf("%d\n", t);
}
return 0;
}