L2-012. 关于堆的判断

本文介绍了一种通过构建小顶堆并利用该结构进行命题判断的方法。具体地,介绍了如何将一系列数字插入到小顶堆中,并根据堆中元素的位置关系判断特定命题的真假。此外,还提供了一个具体的C++代码实现示例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目如下


L2-012. 关于堆的判断

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • “x is the root”:x是根结点;
  • “x and y are siblings”:x和y是兄弟结点;
  • “x is the parent of y”:x是y的父结点;
  • “x is a child of y”:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(<= 1000)和M(<= 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[-10000, 10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出“T”,否则输出“F”。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T
其实这道题重点就是建树,用前面那个实现堆的结构的建树模板就可以,后面判断时只要根据每个数在数组的下标来计算判断就ok了,
但是需要记录每个节点的下标,刚开始我用的数组来记录,提交只过了一个案例,后来发现节点还可以是负数,这时就不能用数组来记
录,于是换成了map,键为节点数值,值为下标,就可以了。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>

using namespace std;

int n, a[1005];

//建树的 “模板”
void up( int son )
{
    int t = a[son];
    int tson = son;
    while( (tson > 1)&&( a[tson/2] > t))
    {
        a[tson] = a[tson/2];
        tson = tson/2;
    }
    a[tson] = t;
}

void charu( int  t)
{
    a[ ++n ] = t;
    up( n );
}


int main ()
{
    int k, m, x, y;;
    map <int, int> index; //记录下标
    string s;
    cin >> k >> m;
    n=0;
    //建树
    for(int i=0; i<k; i++)
    {
        cin >> x;
        charu(x);
    }
    //给map赋值
    for(int i=1; i<=n; i++)
    {
        index[a[i]] = i;
    }
    for(int i=0; i<m; i++)
    {
        cin >> x;
        cin >> s;
        int index_x = index[x]; 
        int index_y;
        if(s[0] == 'a')
        {
            cin >> y;
            getline(cin, s);  //这个函数可以输入一个带空格的字符串
            index_y = index[y];
            if(index_x/2 == index_y/2)
                puts("T");
            else
                puts("F");
        }
        else
        {
            cin >> s;
            cin >> s;
            if(s[0] == 'r')
            {
                if(index_x == 1)
                    puts("T");
                else
                    puts("F");
            }
            else if(s[0] == 'p')
            {
                cin >> s;
                cin >> y;
                index_y = index[y];
                if(index_y/2 == index_x)
                    puts("T");
                else
                    puts("F");

            }
            else
            {
                cin >> s;
                cin >> y;
                index_y = index[y];
                if(index_x/2 == index_y)
                    puts("T");
                else
                    puts("F");
            }
        }
    }

    return 0;
}


### 关于的数据结构判断问题及其Java实现 #### 定义与特性 是一种特殊的完全二叉树,分为最大和最小两种形式。对于最大而言,任意节点的键值总是大于等于其子节点的键值;而对于最小,则相反,即任意节点的键值小于等于其子节点的键值[^1]。 #### PTA L2-012 判断逻辑解析 针对L2-012中的具体需求,程序需接收一组整数作为输入并构建相应的最小或最大(取决于题目要求),之后依据特定条件验证若干命题的真实性。这些命题涉及根节点、兄弟关系、父子关系等方面的内容[^4]。 #### Java代码实例展示 下面给出一段用于解决上述问题的核心部分——向已有的最小中插入新元素,并提供辅助函数来执行各种类型的查询: ```java import java.util.*; public class MinHeap { private List<Integer> heap; public MinHeap() { this.heap = new ArrayList<>(); // 初始化时加入哨兵元素以便简化索引计算 this.heap.add(Integer.MIN_VALUE); } /** * 向最小内添加新的数值 */ public void insert(int value){ int index = heap.size(); heap.add(value); while (index / 2 > 0 && heap.get(index/2) > heap.get(index)){ swap(index, index/2); index /= 2; } } /** * 获取指定位置处的左孩子下标 */ private static int getLeftChildIndex(int parentIndex){ return parentIndex*2; } /** * 获取指定位置处的右孩子下标 */ private static int getRightChildIndex(int parentIndex){ return parentIndex*2 + 1; } /** * 判断两个给定的位置是否互为兄弟节点 */ public boolean areSiblings(int x, int y){ if(x <= 0 || y <= 0 || x >= heap.size() || y >= heap.size()) throw new IndexOutOfBoundsException(); return getParentIndex(x)==getParentIndex(y)&&x!=y; } /** * 返回某节点的父亲节点所在数组里的序号 */ private static int getParentIndex(int childIndex){ return childIndex/2; } /** * 查询某个数字是不是当前顶元素 */ public boolean isRoot(int target){ return !heap.isEmpty()&&target==heap.get(1); } /** * 验证是否存在这样的亲子关系:parent->child */ public boolean hasParentChildRelation(int parent,int child){ if(child<=0||parent<=0||child>=heap.size()||parent>=heap.size()) throw new IndexOutOfBoundsException(); return getParentIndex(child)==parent; } /** * 执行交换操作 */ private void swap(int i, int j){ Collections.swap(heap,i,j); } } ``` 这段代码实现了基本的小根功能,包括但不限于插入新成员、查找根节点、确认两节点间的关系等常用方法。通过调用`insert()`可以逐步建立起所需的结构,而其他几个公开的方法则可用于完成后续的各种检验工作。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值