1142 Maximal Clique

文章描述了一个关于图论的问题,给出一个无向图,判断给定的顶点子集是否能组成一个最大cliques。通过检查子集内顶点间的相邻关系以及扩展性来确定答案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

思路

cpp代码

#include<iostream>
#include<vector>
#include<cstring>
using namespace std;
const int N=210;
int g[N][N];
int n,m;
bool st[N];
bool check_a(vector<int> vec){
    for(auto i:vec){
        for(auto j:vec){
            if(i!=j){
                if(!g[i][j]||!g[j][i])return false;
            }
        }
    }
    return true;
}
bool check_b(vector<int> vec){

    for(auto i:vec)st[i]=true;

    for(int i=1;i<=n;i++){
        bool flag=true;
        if(!st[i]){//剩余不在团内的点
            for(auto j:vec){
                if(!g[j][i]||!g[i][j]){
                    flag=false;
                    break;
                }
            }
            if(flag)return false;
        }
    }
    return true;
}
int main(){
    cin>>n>>m;
    for(int i=0;i<m;i++){
        int a,b;
        cin>>a>>b;
        g[a][b]=1;
        g[b][a]=1;
    }
    int q;
    cin>>q;
    while(q--){
        memset(st,false,sizeof st);
        int k;
        cin>>k;
        vector<int> vec;
        for(int i=0;i<k;i++){
            int x;
            cin>>x;
            vec.push_back(x);
        }
        if(!check_a(vec)){
            puts("Not a Clique");
        }
        else {
            if(!check_b(vec))puts("Not Maximal");
            else puts("Yes");
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值