1168 Prime Day

The above picture is from Sina Weibo, showing May 23rd, 2019 as a very cool “Prime Day”. That is, not only that the corresponding number of the date 20190523 is a prime, but all its sub-strings ended at the last digit 3 are prime numbers.

Now your job is to tell if a given date is a Prime Day.

Input Specification:

Each input file contains one test case. For each case, a date between January 1st, 0001 and December 31st, 9999 is given, in the format yyyymmdd.

Output Specification:

For each given date, output in the decreasing order of the length of the substrings, each occupies a line. In each line, print the string first, followed by a space, then Yes if it is a prime number, or No if not. If this date is a Prime Day, print in the last line All Prime!.

Sample Input:

20190523

Sample Output:

20191231 Yes
0191231 Yes
191231 Yes
91231 No
1231 Yes
231 No
31 Yes
1 No

思路

字符串操作、数学题

cpp代码

#include<iostream>
using namespace std;
bool check(int x){
	if(x<2)return false;
	for(int i=2;i<=x/i;i++)
		if(x%i==0)return false;
	
	return true;
}
int main(){
	string s;
	cin>>s;
	bool st=true;
	for(int i=0;i<s.size();i++){
		string str=s.substr(i);
		int x=stoi(str);
		if(check(x)){cout<<str<<" "<<"Yes"<<endl;}
		else {
			st=false;
			cout<<str<<" "<<"No"<<endl;
		}
	}
	if(st)puts("All Prime!");
	return 0;
} 
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值