A safari park(野生动物园)has K species of animals, and is divided into N regions. The managers hope to spread the animals to all the regions, but not the same animals in the two neighboring regions. Of course, they also realize that this is an NP complete problem, you are not expected to solve it. Instead, they have designed several distribution plans. Your job is to write a program to help them tell if a plan is feasible.
Input Specification:
Each input file contains one test case. For each case, the first line gives 3 integers: N (0<N≤500), the number of regions; R (≥0), the number of neighboring relations, and K (0<K≤N), the number of species of animals. The regions and the species are both indexed from 1 to N.
Then R lines follow, each gives the indices of a pair of neighboring regions, separated by a space.
Finally there is a positive M (≤20) followed by M lines of distribution plans. Each plan gives N indices of species in a line (the i-th index is the animal in the i-th rigion), separated by spaces. It is guaranteed that any pair of neighboring regions must be different, and there is no duplicated neighboring relations.
Output Specification:
For each plan, print in a line Yes if no animals in the two neighboring regions are the same, or No otherwise. However, if the number of species given in a plan is not K, you must print Error: Too many species. or Error: Too few species. according to the case.
Sample Input:
6 8 3
2 1
1 3
4 6
2 5
2 4
5 4
5 6
3 6
5
1 2 3 3 1 2
1 2 3 4 5 6
4 5 6 6 4 5
2 3 4 2 3 4
2 2 2 2 2 2
Sample Output:
Yes
Error: Too many species.
Yes
No
Error: Too few species.
思路
题目大意是说先给出一些边,表示这些regions相邻,然后所有的动物,不同的数字代表不同的物种,如果物种小于k输出Error: Too few species,大于则输出Error: Too many species,这里可以用um、set处理。然后循环遍历,在物种相同时判断是不是相邻即可
cpp代码
#include<iostream>
#include<unordered_map>
#include<vector>
#include<set>
using namespace std;
int n,m,k;
vector<pair<int,int>> g;
int main(){
cin>>n>>m>>k;
for(int i=0;i<m;i++){
int a,b;
cin>>a>>b;
g.push_back({a,b});
}
int q;
cin>>q;
while(q--){
vector<int> vec;
unordered_map<int,int> Hash;
for(int i=0;i<n;i++){
int c;
cin>>c;
Hash[c]++;
vec.push_back(c);
}
if(Hash.size()<k){
puts("Error: Too few species.");
continue;
}else if(Hash.size()>k){
puts("Error: Too many species.");
continue;
}
else{
bool st=true;
for(auto i:g){
int x=i.first,y=i.second;
if(vec[x-1]==vec[y-1]){
st=false;
break;
}
}
if(st)puts("Yes");
else puts("No");
}
}
return 0;
}