Given a singly linked list L. Let us consider every K nodes as a block (if there are less than K nodes at the end of the list, the rest of the nodes are still considered as a block). Your job is to reverse all the blocks in L. For example, given L as 1→2→3→4→5→6→7→8 and K as 3, your output must be 7→8→4→5→6→1→2→3.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
5
) which is the total number of nodes, and a positive K (≤N) which is the size of a block. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.
Output Specification:
or each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218
Sample Output:
71120 7 88666
88666 8 00000
00000 4 99999
99999 5 68237
68237 6 00100
00100 1 12309
12309 2 33218
33218 3 -1
思路
根据address关键字存data和next,然后从头结点开始把整个单链表串联起来放在vector里面
先总体翻转一遍,序列前面的部分不足k先翻转,然后每隔k翻转一遍
最后整理输出即可
cpp代码
#include<iostream>
#include<algorithm>
#include<unordered_map>
#include<vector>
using namespace std;
unordered_map<int,int> da,ne;
vector<pair<int,int>> vec;
int main(){
int h1,n,k;
cin>>h1>>n>>k;
for(int i=0;i<n;i++){
int a,b,c;
cin>>a>>b>>c;
da[a]=b;
ne[a]=c;
}
for(int i=h1;~i;i=ne[i])vec.push_back({i,da[i]});
reverse(vec.begin(),vec.end());
int t=vec.size()%k;
if(t)reverse(vec.begin(),vec.begin()+t);
for(int i=t;i<vec.size();i+=k)
reverse(vec.begin()+i,min(vec.begin()+i+k,vec.end()));
for(int i=0;i<vec.size();i++){
if(i==vec.size()-1)
printf("%05d %d -1\n",vec[i].first,vec[i].second);
else
printf("%05d %d %05d\n",vec[i].first,vec[i].second,vec[i+1].first);
}
return 0;
}