问题描述:
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
样例输入:
2
2
20 25
40
1
8
样例输出:
08:00:40 am
08:00:08 am
问题大意:
为了早点下班,电影院售票员可以卖一张票或者相邻的两张票。
第一行为样例输入个数 K。
第二行
K个整数(0s<=Si<=25s),表示每人购买一张票所花费的时间;
第三行
(K-1)整数(0s<=Di<=50s),表示两个相邻的人一起购买两张票所需的时间。
输出
对于每种情况,请告诉乔他什么时候可以尽早回家。乔每天早上8:00开始工作。时间格式为HH:MM:SS am | pm。
思路分析:
用一个数组存单个买票的时间,一个数组存当前人和前一个人合买的时间。
进行比较后,找到最小的值。
解决方案:
#include "stdio.h"
#include "string.h"
#include "algorithm"
using namespace std;
int main ()
{
int a[11000],b[11000];
int dp[11000];
int n,m,i,j,k,s;
scanf("%d",&m);
while(m--)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
for(i=2;i<=n;i++)
scanf("%d",&b[i]);
memset(dp,0,sizeof(dp));
//
if(n==1)
s=a[1];
else if(n==2)
s=min(b[2],a[1]+a[2]);
//这一部分是最简单的情况,直接特判就可,也可以写在下面的程序中。
else
{
dp[0]=0;
dp[1]=a[1];
for(i=2;i<=n;i++)
{
dp[i]=min(dp[i-2]+b[i],dp[i-1]+a[i]);//记录最小的值
printf("&&%d\n",dp[i]);
}
s=dp[n]; //结果。
}
//转换格式。
int xs,fz,miao;
miao=s%60;
fz=s/60%60;
xs=s/3600+8;
if(xs>12)//超过12点为下午。
printf("%02d:%02d:%02d pm\n",xs-12,fz,miao);
else
printf("%02d:%02d:%02d am\n",xs,fz,miao);
}
return 0;
}