Description
动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
有人用两种说法对这N个动物所构成的食物链关系进行描述:
第一种说法是"1 X Y",表示X和Y是同类。
第二种说法是"2 X Y",表示X吃Y。
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
1) 当前的话与前面的某些真的话冲突,就是假话;
2) 当前的话中X或Y比N大,就是假话;
3) 当前的话表示X吃X,就是假话。
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。
Input
第一行是两个整数N和K,以一个空格分隔。
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
若D=1,则表示X和Y是同类。
若D=2,则表示X吃Y。
Output
只有一个整数,表示假话的数目。
Sample Input
100 7
1 101 1
2 1 2
2 2 3
2 3 3
1 1 3
2 3 1
1 5 5
Sample Output
3
具体思路
在顶部的向量路径压缩链接中,大牛的思路真的强,将并查集的路径听过三者之间的关系建立向量路径压缩
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<queue>
#include<string.h>
#include<stack>
using namespace std;
const int maxdot=50050;
struct node
{
int pre;
int relation;
}dot[maxdot];
int findroot(int x)
{
int now;
if(x == dot[x].pre)
{
return x;
}
now = dot[x].pre;
dot[x].pre = findroot(now);
dot[x].relation = (dot[x].relation + dot[now].relation) % 3;
return dot[x].pre;
}
void init(int n)
{
for(int i=1;i<=n;i++)
{
dot[i].pre=i;
dot[i].relation=0;
}
return ;
}
int main()
{
int n,k,ans=0,d,x,y;
scanf("%d%d",&n,&k);
init(n);
for(int i=1;i<=k;i++)
{
scanf("%d%d%d",&d,&x,&y);
if(x>n||y>n)
{
ans++;
continue;
}
if(d==2&&x==y)
{
ans++;
continue;
}
int oneroot=findroot(x),otherroot=findroot(y);
if(oneroot!=otherroot)
{
dot[otherroot].pre=oneroot;
dot[otherroot].relation=(3+(d-1)+dot[x].relation-dot[y].relation) % 3;
}else
{
if(d==1&&dot[x].relation!=dot[y].relation)
{
ans++;
continue;
}
if(d==2&&((3-dot[x].relation+dot[y].relation)%3!=d-1))
{
ans++;
continue;
}
}
}
printf("%d\n", ans);
return 0;
}