1122 Hamiltonian Cycle (25 分)(图论)

本文探讨了汉密尔顿回路问题,一种寻找包含图中所有顶点的简单回路的经典图论问题。提供了判断给定路径是否构成汉密尔顿回路的算法实现,包括输入输出规格说明及示例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V

1

V

2

... V

n

where n is the number of vertices in the list, and V

i

's are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10

6 2

3 4

1 5

2 5

3 1

4 1

1 6

6 3

1 2

4 5

6

7 5 1 4 3 6 2 5

6 5 1 4 3 6 2

9 6 2 1 6 3 4 5 2 6

4 1 2 5 1

7 6 1 3 4 5 2 6

7 6 1 2 5 4 3 1

Sample Output:

YES

NO

NO

NO

YES

NO

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
#include <unordered_set>
using namespace std;
int e[210][210];
int main() {
    int n,m,k,cnt;
    cin>>n>>m;
    for(int i=0;i<m;i++){
        int t1,t2;
        cin>>t1>>t2;
        e[t1][t2]=e[t2][t1]=1;
    }
    cin>>cnt;
    for(int i=0;i<cnt;i++){
        cin>>k;
        vector<int> v(k);
        set<int> s;
        int flag1=1,flag2=1;
        for(int j=0;j<k;j++){
            cin>>v[j];
            s.insert(v[j]);
        }
        if(s.size()!=n||k-1!=n||v[0]!=v[k-1]) flag1=0;
        for(int j=0;j<k-1;j++)
            if(e[v[j]][v[j+1]]==0) flag2=0;
        printf("%s",flag1&&flag2?"YES\n":"NO\n");
    }
    return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小火汁猛猛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值