目录
题目:
Maximum sum
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 43867 | Accepted: 13643 |
Description
Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).
Input
The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.
Output
Print exactly one line for each test case. The line should contain the integer d(A).
Sample Input
1 10 1 -1 2 2 3 -3 4 -4 5 -5
Sample Output
13
Hint
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.
Huge input,scanf is recommended.
题目大意:
给出一串数字,要求从中选出两个部分使得,这两个子串和最大。
思路:
这是一道很经典的dp问题,先顺序遍历一遍,将当前位置的最大前缀和用dp数组记录,然后逆序遍历一遍将当前位置最大前缀和与dp数组加和求最大值
AC代码:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<ctime>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int N = 1e5 + 7;
int dp[N],a[N];
int main()
{
int t;
scanf("%d",&t);
while(t--){
int n,temp = -inf,maxn = -inf,ans = -inf;
scanf("%d",&n);
memset(dp,0,sizeof dp);
for(int i = 0;i < n;++i) scanf("%d",&a[i]);
for(int i = 0;i < n;++i){
temp = temp >= 0 ? temp + a[i] : a[i] ;
if(temp > maxn){
maxn = temp;
dp[i] = maxn;
}
}
temp = maxn = -inf;
for(int i = n - 1;i > 0;--i){
temp = temp >= 0 ? temp + a[i] : a[i];
if(temp > maxn) maxn = temp;
if(maxn + dp[i - 1] > ans) ans = maxn + dp[i - 1];
}
printf("%d\n",ans);
}
return 0;
}