There is a very simple and interesting one-person game. You have 3 dice, namely Die1, Die2 and Die3. Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1, K2, K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:
- Set the counter to 0 at first.
- Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
- If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.
Calculate the expectation of the number of times that you cast dice before the end of the game.
Input
There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers n, K1, K2, K3, a, b, c (0 <= n <= 500, 1 < K1, K2, K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).
Output
For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.
Sample Input
2 0 2 2 2 1 1 1 0 6 6 6 1 1 1
Sample Output
1.142857142857143 1.004651162790698
这题实在是……太巧妙了 只能说kuangbin牛逼。
https://blog.youkuaiyun.com/qingshui23/article/details/77776018这篇文章的公式贴的比较好,实际你会发现网上关于这道题的题解都大同小异,因为kuangbin实在是牛逼。
稍微补充一点就是,p0其实是三面各为一个特定值的概率,所以清零的概率也是p0,甩出点数和为x的概率就是三个骰子有多少种方式组成x再乘个p0
AC代码:
#include <bits/stdc++.h>
using namespace std;
const int maxn=520;
double A[maxn];
double B[maxn];
double p[maxn];
double p0;
int n,k1,k2,k3,a,b,c;
void getp()
{
for(int i=1;i<=k1;i++)
for(int j=1;j<=k2;j++)
for(int k=1;k<=k3;k++)
{
if(i!=a||j!=b||k!=c)
p[i+j+k]+=p0;
}
}
int main()
{
int t;
cin>>t;
while(t--)
{
cin>>n>>k1>>k2>>k3>>a>>b>>c;
memset(p,0,sizeof(p));
memset(A,0,sizeof(A));
memset(B,0,sizeof(B));
p0=1.0/(k1*k2*k3);
getp();
for(int i=n;i>=0;i--)
{
for(int j=3;j<=k1+k2+k3;j++)
{
A[i]+=p[j]*A[i+j];
B[i]+=p[j]*B[i+j];
}
A[i]+=p0;
B[i]+=1;
}
printf("%.15f\n",B[0]/(1-A[0]));
}
return 0;
}