[Usaco2005 Jan]Moo Volume 牛的呼声

[Usaco2005 Jan]Moo Volume 牛的呼声

Description

Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise. FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.

    约翰的邻居鲍勃控告约翰家的牛们太会叫.
    约翰的N(1≤N≤10000)只牛在一维的草场上的不同地点吃着草.她们都是些爱说闲话的奶牛,每一只同时与其他N-1只牛聊着天.一个对话的进行,需要两只牛都按照和她们间距离等大的音量吼叫,因此草场上存在着N(N-1)/2个声音.  请计算这些音量的和

Input

* Line 1: N * Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).

    第1行输入N,接下来输入N个整数,表示一只牛所在的位置.

Output

* Line 1: A single integer, the total volume of all the MOOs.

    一个整数,表示总音量.

Sample Input

5
1
5
3
2
4

INPUT DETAILS:

There are five cows at locations 1, 5, 3, 2, and 4.
Sample Output
40

OUTPUT DETAILS:

Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3
contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4
contributes 3+2+1+1=7.  The total volume is (10+10+6+7+7) = 40.

 

题目给出N个数,求每两个数之差的绝对值。

由于N(1≤N≤10000),所以本题只能用O(N)的时间复杂度。

abs(num[a]-num[b])=(num[a+1]-num[a])+(num[a+2]-num[a+1])...+(num[b]-num[b-1])。(a<b)

升序排列。

我们可以把abs(num[a]-num[b])看做一小段一小段编号相邻的两个数距离(num[i+1]-num[i])之和,那么abs(num[a]-num[b])就是由这几段组成。我们只要得出每一段被加了几次,就可以得出答案了。

(num[i+1]-num[i])的左端点可以为第1,2...,(i-1),k个数,共k个数;右端点可以为第(i+1),(i+2)...,(n-1),n个数,共(n-i)个数。所以跟据乘法原理,共有i(n-i)段,故ans=ans+i*(n-i)*(num[i+1]-num[i])

由于是双向的,所以abs(num[i+1]-num[i])与abs(num[i]-num[i+1])被看做是不同的,所以最后ans*2

注意:因为N(1≤N≤10000),且num[i](0..1,000,000,000),所以ans需要开long long;因为i是int,所以要强行转long long。

 

#include<bits/stdc++.h>
using namespace std;
int n,num[10010];
long long ans=0;//注意ans要开long long 
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
		scanf("%d",&num[i]);
	sort(num+1,num+1+n);//升序排列 
	for(int i=1;i<n;i++)
		ans=ans+(long long)(i)*(n-i)*(num[i+1]-num[i]);//强制转long long
	printf("%lld",ans*2);
	return 0;	
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值