UVA-10003 Cutting Sticks (动规-四边形不等式dp)

题目:

          You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time. It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.

           Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

Input

The input will consist of several input cases. The first line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n (n < 50) of cuts to be made. The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order. An input case with l = 0 will represent the end of the input.

Output

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

Sample Input

100

3

25 50 75

10

4

4 5 7 8

0

Sample Output

The minimum cutting is 200.

The minimum cutting is 22.

题意:给你n个切割点,让你将木棒切成n+1段,

          每次切割的代价是切割前木棒的长度

         让求将所有的切割点切完后,所消耗的代价最小值

 

正常代码:(O(N^3))

//核心方程式:dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+a[j]-a[i-1]);
//a[j]-a[i-1]表示留下i~j的长度; 
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define inf 0x3f3f3f3f
#define N 1005
using namespace std;
int a[N],dp[N][N];
int main() {
	int l,n;
	while(~scanf("%d",&l)&&l) {
		scanf("%d",&n);
		for(int i=1; i<=n; i++)
			scanf("%d",&a[i]);
		a[n+1]=l;
		memset(dp,inf,sizeof(dp));
		//dp[i][j]表示切割i~j处的不棒 
		for(int i=1; i<=n+1; i++)
			dp[i][i]=0;
		for(int i=n; i>=1; i--)//从倒数第二个往前枚举 
			for(int j=i+1; j<=n+1; j++)//定位j的区间 
				for(int k=i; k<j; k++)//方程式决定是否在i~j处切割k点 
					dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+a[j]-a[i-1]);
		printf("The minimum cutting is %d.\n",dp[1][n+1]);//输出整个切完后的代价最小值 
	}
}

优化: O(N^2)

// 优化:
#include<cstdio>
#include<cstring>
#include<iostream>
#define inf 0x3f3f3f3f
#define N 55
using namespace std;
int dp[N][N],s[N][N],a[N];//s记录区间最优的位置
int main() {
	int l,n;
	while(~scanf("%d",&l)&&l) {
		scanf("%d",&n);
		for(int i=1; i<=n; i++)
			scanf("%d",&a[i]);
		a[n+1]=l;
		n++;//******
		memset(dp,inf,sizeof(dp));
		for(int i=1; i<=n; i++) {
			dp[i][i]=0;
			s[i][i+1]=i;
		}
		for(int i=1; i<=n; i++)
			dp[i][i+1]=a[i+1]-a[i-1];
			
		for(int i=n-2; i>=1; i--)
			for(int j=i+1; j<=n; j++)
				for(int k=s[i][j-1]; k<=s[i+1][j]; k++) 
					if(dp[i][j]>dp[i][k]+dp[k+1][j]+a[j]-a[i-1])
					{
						dp[i][j]=dp[i][k]+dp[k+1][j]+a[j]-a[i-1];
						s[i][j]=k;
					}
		printf("The minimum cutting is %d.\n",dp[1][n]);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值